klykovav672
?>

Составить программу(паскаль) сформировать массив (t кол-во элементов 20) случайных чисел, выбранных на интервале от -10 до +10.вывести кол-во нулевых элементов, сумму элементов кратных 3 и среднее арифметическое всех элементов массива.

Информатика

Ответы

pavelriga5

var t: array[0..19] of byte;

      i,k,l,s: integer;

begin      

 

k: =0;

l: =0;

s: =0;

for i: =0 to 19 do begin

t[i]: =random(21)-10;

write(t[i],'   ');

if t[i]=0 then k: =k+1;

if t[i] mod 3=0 then s: =s+t[i];

l: =l+t[i];

end;

 

write('колво 0   ',k);

write('сумма кратных 3 ',s);

write('средне арефм ',l/20);  

    end.

алексеевич810
1) i =log2 (39) = 5,285 бит (если надо в целых, то   i =6 бит) 2)   n=2^i =2^12 = 4096 количество событий 3) 1+6=7       i = log2 7 = 2,81 бит количество информации о цвете 4) 1+6=7 р=1/7 - вероятность, что достали белый шар     i=-log2(1/7) = log2 7 =2,81 бит в сообщении, что достали белый шар 5) в сообщении 24 символа (без точки в конце) в ascii 1 символ кодируется 8-ю битами (=1 байт) 24*1 байт =24 байта.             ( если в конце предложения есть точка, то тогда 25 байтов) 6) текст на кириллице, 1символ=1 байту     24байта ( или с точкой -25 байтов)
zverevahelen

модель  — это  искусственно создаваемый объект, заменяющий некоторый объект реального мира (объект моделирования) и воспроизводящий ограниченное число его свойств.  понятие модели относится к общенаучным понятиям, а моделирование — это метод познания действительности, используемый различными науками.

формализация  к предметной области информатики относятся средства и методы компьютерного моделирования. компьютерная модель может быть создана только на основе хорошо формализованной информационной модели. что же такое формализация?

формализация информации  о некотором объекте — это  ее отражение в определенной форме.  можно еще сказать так: формализация — это сведение содержания к форме. формулы, описывающие процессы, — это формализация этих процессов. радиосхема электронного устройства — это формализация функционирования этого устройства. ноты, записанные на нотном листе, — это формализация музыки и т.п

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу(паскаль) сформировать массив (t кол-во элементов 20) случайных чисел, выбранных на интервале от -10 до +10.вывести кол-во нулевых элементов, сумму элементов кратных 3 и среднее арифметическое всех элементов массива.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Остап-Лаврова1410
macmakka
vladimir152
Pavlov447
gorbelena1971
Salnikov1730
parolmm
Yulechkaakulova1993
Герасимова107
Yevgenevna
Вадим-Рашад323
slspam
ninakucherowa
elvini857