1)
#include <iostream>
#include <cmath>
#include <vector>
#include <algorithm>
using namespace std;
signed main() {
ios_base::sync_with_stdio(0);
cin.tie(0);
cout.tie(0);
int n;
cin >> n;
int a[n][n];
int mn = INT_MAX;
for(int i = 0; i < n; i++)
{
for(int j = 0; j < n; j++)
{
cin >> a[i][j];
mn = min(mn,a[i][j]);
}
}
vector<pair<int,int>> vec;
for(int i = 0; i < n; i++)
for(int j = 0; j < n; j++)
if(a[i][j] == mn)
vec.push_back(make_pair(i,j));
cout << mn << "\n";
for(auto i: vec)
cout << i.first << " " << i.second << "\n";
}
2)
#include <iostream>
#include <cmath>
#include <vector>
#include <algorithm>
using namespace std;
signed main() {
ios_base::sync_with_stdio(0);
cin.tie(0);
cout.tie(0);
int n,m;
cin >> n >> m;
int a[n][m];
for(int i = 0; i < n; i++)
{
int mid = 0;
for(int j = 0; j < m; j++)
{
cin >> a[i][j];
mid += a[i][j];
}
mid /= m;
a[i][0] = mid;
}
for(int i = 0; i < n; i++)
{
for(int j = 0; j < m; j++)
cout << a[i][j] << " ";
cout << "\n";
}
}
Выберите ВЕРНОЕ имя переменной:
name6
Program
При какого оператора в Паскаль вводится значения переменной с клавиатуры:
Read
При какого оператора в Паскаль выводится сообщение на экран:
Writeln
Выберите ВЕРНУЮ запись оператора Writeln, выводящую на экран значение переменной a:
Writeln('ответ', a):
Пользователю нужно составить программу, находящую квадрат вещественного числа. Выберите верный фрагмент программы:
Вариант 4
Пользователю нужно составить программу, находящую квадрат любого числа. Выберите верный вариант программы:
Тут из за пикселизации, я не понял
либо 1 вариант либо 2
Дан фрагмент программы. Укажите пропущенный оператор:
begin
Дан текст программы. После запуска выдает ошибку. Исправьте программу, изменив ОДНУ строку. В ответе укажите ВЕРНУЮ запись этой строки:
read (a);
Что будет напечатано в результате работы программы:
ответ 12
Что будет напечатано в результате работы программы:
2
Что будет напечатано в результате работы программы:
3
Поделитесь своими знаниями, ответьте на вопрос:
Вматрице хранится информация о зарплате n-участников за каждый месяц года. определить среднюю зарплату за каждый месяц и в каком месяце средняя зарплата была самой высокой. паскаль.
var
a:array[1..n,1..m] of integer;
i,j,s,max,imax:integer;
begin
Randomize;
writeln('Зарплата за год:');
for i:=1 to n do
begin
for j:=1 to m do
begin
a[i,j]:=random(15000)+10000;
write(a[i,j]:6);
end;
writeln;
end;
writeln('Средние зарплаты по месяцам:');
max:=0;
for j:=1 to m do
begin
s:=0;
for i:=1 to n do s:=s+a[i,j];
write(s/n:5:2,' ');
if s>max then begin max:=s; imax:=j; end;
end;
writeln;
writeln('max = ',max/n:5:2,' месяц:',imax);
end.
Пример (для 4 месяцев, т.е. m=4):
Зарплата за год:
12533 11176 15153 14194
12649 22212 15546 17586
23643 15664 15538 21740
24382 10015 15816 24377
11388 12739 18790 21034
Средние зарплаты по месяцам:
16919.00 14361.20 16168.60 19786.20
max = 19786.20 месяц:4