festjob
?>

Дано целое число а. если значение а > 0, то необходимо увеличить его на единицу, иначе уменьшить на 1. написать программу для решения этой . протестировать программу для a=3, a=0, a=-12.

Информатика

Ответы

shalunovroman
Program abc;
var a:real;
begin
readln (a);
if (a>0) then a:=a+1 else a:=a-1;
writeln (a);
readkey;
end.
soclive7762
Компьютер — самый необычный инструмент из всех придуманных человеком. Он используется не в материальной, а в умственной, интеллектуальной деятельности людей разных профессий: экономистов, конструкторов, переводчиков, психологов, физиков, художников...

Возможности своего интеллектуального человек постоянно старается расширить. Для этого не только совершенствуется оборудование, «железо» компьютера, но и создаются новые компьютерные программы, программные средства. Эти программы составляются программистами — специалистами в области информатики.


Зачем нужны компьютерные программы? Компьютер часто называют «умной» машиной, однако он не обладает человеческим разумом. Человек действует, когда захочет этого сам, или по заданию других людей. Компьютер ничего не делает «по собственному хотению». Все действия он выполняет только по заданию человека. Для управления действиями компьютера и предназначены компьютерные программы.

Могут ли программисты составлять компьютерные программы без участия других специалистов? Пусть, например, программа предназначена для авиаконструктора или модельера-парикмахера, тогда программисту потребуется представителей этих профессий. Только специалисты смогут подробно рассказать, с какими предметами, персонажами и явлениями они имеют дело в своей работе, что может происходить со всеми этими объектами, как принимаются решения. На месте такого специалиста может оказаться в будущем любой из вас, какую бы профессию он ни выбрал.

 Может ли человек, не изучавший информатику, рассказать о своей работе, учебе или любимой игре? Наверное, да. Но одно дело, когда рассказ предназначен для другого человека, и совсем другое, когда сведения нужны для создания компьютерной программы. Объясняя что-то людям, мы можем не вдаваться в какие-то подробности, полагаясь на их опыт, знания, сообразительность. В описаниях, которые составляются при создании компьютерных программ, не должно быть ничего лишнего, но в то же время они не могут полагаться на чей-то опыт или смекалку.

 И еще: эти описания нужно представить не в форме устного рассказа или повести, а в виде наглядных и компактных схем, таблиц, списков. Составлению таких «компьютерных» описаний нужно специально учиться — изучать информатику. Полученные знания и умения можно использовать не только при создании компьютерных программ. Они пригодятся всем, кому приходится составлять описания, инструкции, объяснения. А ведь делать это приходится практически каждому человеку — в любом возрасте и в самых различных ситуациях. 
Shamil
      1         1          1      1        0      0     1      1
463/2=231/2=115/2=57/2=28/2=14/2=7/2=3/2=1 Важно разделить число так чтобы оно было без остатка если допустим число 463 не делится на 2 значит надо занять 1 тогда будет число 462 его разделим на 2 и т.д. а эту единицу необходимо записать над знаком деления если число делится пишим 0 над знаком деления и записываем получившееся число с права налево получается число 11001111
также и в восьмеричной системе счисления пишим остаток над знаком деления
       7      1  
463/8=57/8=7 ответ 717
Аналогично в 16 ричной СС
      15       12
463/16=28/16=1 так как 15 у нас равно Е а 12 С ответ будет 1СЕ
B)     1         0       0           1       1       1       0     1     0     0   
1209/2=604/2=302/2=151/2=75/2=37/2=18/2=9/2=4/2=2/2=1 ответ с права налево 10010111001
        1         7       2
1209/8=151/8=18/8=2 ответ 2271
         9         В   
1209/16=75/16=4 ответ 4В9
С)   0       1         0       1      0       1      1    0  
362/2=181/2=90/2=45/2=22/2=11/2=5/2=2/2=1 ответ 101101010
      2       5
362/8=45/8=5 ответ 552
      А         6
362/16=22/16=1 ответ 16А
D)     1           0       1           0         1          0      1       0       1     1     1
3925/2=1962/2=981/2=490/2=245/2=122/2=61/2=30/2=15/2=7/2=3/2=1 ответ 111101010101
        5          2      5  
3925/8=490/8=61/8=7 ответ 7525
        5            5
3925/16=245/16=15 иил F ответ F55
Е)       1          1            0          1          1         0         1       0       0       0
11355/2=5677/2=2838/2=1419/2=709/2=354/2=177/2=88/2=44/2=22/2=
    1     1     0  
11/2=5/2=2/2=1 ответ 10110001011011
          3           3         1       6
11355/8=1419/8=177/8=22/8=2 ответ 26133
          В          5          С
11355/16=709/16=44/16=2 ответ 2С5В

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано целое число а. если значение а > 0, то необходимо увеличить его на единицу, иначе уменьшить на 1. написать программу для решения этой . протестировать программу для a=3, a=0, a=-12.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

yuip2008
Дмитрий Бундин
родичева1812
korolev-comitet8825
Ромеовна1527
Anna389
olqa27
M19026789436
mayorovmisc6
groomingprofi56
Stenenko
Попова1271
rmitin
dentalfamily
lenskiy