ashantik
?>

Написать программу в паскале: даны несколько чисел, указать какие числа чётные, какие нет. указать количество чётных и нечётных чисел, а также найти сумму отдельно чётных и нечётных чисел. !

Информатика

Ответы

yatania-popovich7
Паскаль не пригодится в жизни. учи С++
ilma20168
Тут все

const
    handsfree = true;

var
    a: array[1..100] of real;
    i, n: integer;
    min, max: real;
    sum, product, harmonic: real;
    k: integer;

begin
    {ввод массива}
    if handsfree then
        n := random(20) + 5
    else begin
        write('n = ');
        readln(n);
    end;
   
    writeln('Данные массива:');
    for i := 1 to n do
    begin
        if handsfree then begin
            a[i] := random(100) - 50;
            write(a[i], ' ');
        end
        else readln(a[i]);
    end;
    writeln();
   
    {подсчет элементов}
    k := 0;
    for i := 1 to n do
        if a[i] > 5 then k := k + 1;
    writeln(k);
   
    {минимум и максимум}
    max := a[1];
    min := a[1];
    for i := 1 to n do
    begin
        if max < a[i] then max := a[i];
        if min > a[i] then min := a[i];
    end;
    writeln('max = ', max);
    writeln('min = ', min);
   
    {подсчет суммы и произведения и агригатов}
    sum := 0;
    product := 1;
    harmonic := 1;
    k := 0;
    for i := 1 to n do
    begin
        if true then {если нужен фильтр}
        begin
            sum := sum + a[i];
            product := product * a[i];
            harmonic := harmonic + 1 / a[i];
            k := k + 1;
        end;
    end;
    writeln('sum = ', sum);
    writeln('product = ', product);
    writeln('average = ', sum / n);
    writeln('average (selected) = ', sum / k);
    writeln('harmonic mean = ', n / harmonic);
    writeln('harmonic mean (selected) = ', k / harmonic);
   
    {изменение элементов}
    for i := 1 to n do
    begin
        if a[i] < 0 then
            a[i] := abs(a[i]);
        write(a[i], ' ');
    end;
end.
aa276568
Процессор взаимодействует с оперативной памятью не напрямую, а через специальный контроллер, под­ключенный к системной шине процессора приблизительно так же, как и остальные контроллеры периферийных устройств. Причем механизм обра­щения к портам ввода/вывода и к ячейкам оперативной памяти с точки зре­ния процессора практически идентичен. Процессор сначала выставляет на адресную шину требуемый адрес, а в следующем такте уточняет тип запроса: происходит ли обращение к памяти, портам ввода/вывода или подтвержде­ние прерывания. В некотором смысле оперативную память можно рассмат­ривать как совокупность регистров ввода/вывода, каждый из которых хра­нит некоторое значение.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в паскале: даны несколько чисел, указать какие числа чётные, какие нет. указать количество чётных и нечётных чисел, а также найти сумму отдельно чётных и нечётных чисел. !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vallzh8328
Александр Сергей
svetarakityanskaya
tcmir
kisuhakisa
shilinmikhaillg
Bogataya Vladimir318
Voronin-Albertovich
nunabat457
teya07
Жуков219
Акимцева27
uvarovig
lider-mpl550
Mbkozlov6