purchase
?>

Написать программу, которая из последовательности чисел от -40 до 30 выбирает те, которые отрицательные, меняет их знак и делит на 7. построить блок-схему и написать программу, .

Информатика

Ответы

Энверович
Begin
  var a := Range(-40, 30);
  a.Println();
  writeln('');
  a.Where(x -> x < 0).Select(x -> (- x) / 7).Print();
end.
plio67380
Program;
var a,i:integer;
Begin
for i:=-40 to 30 do
read(a);
begin
if (a<0) then
a:=a*(-1);
a:=a/7;
end;
write(a);
End.
mayskiyandrey90
Точная задача по Техническому Заданию:
var x,y:integer;
begin
writeln('введите два числа');
readln(x);
readln(y);
if (x<1000000001) and (y<1000000001) and (x>0) and (y>0)
then writeln('сумма чисел =',x+y)
else writeln('диапазон чисел неверный');
end.

Если вдруг вам поверит учитель, можете перевыполнить поставленную задачу:
var x,y:integer;      
      s:string;
begin
randomize;
writeln('взять ли числа случайными? ответ да или нет');
readln(s);
if (s='да') or (s='Да') or (s='ДА') or (s='дА') then begin
x:=random(1000000000);
y:=random(1000000000);
writeln('сумма чисел =',x+y);
writeln('произведение чисел =',x*y);  
end
else begin
writeln('введите два числа');
readln(x);
readln(y);
writeln('сумма чисел =',x+y);
writeln('произведение чисел =',x*y);
end;
end.
mikchaylovaalex

нц пока не сверху свободно

закрасить

вправо

кц

 

нц пока сверху свободно

вправо

кц

 

нц пока справа свободно

закрасить

вправо

кц

 

нц пока не справа свободно

закрасить

вниз

кц

 

нц пока справа свободно

вниз

кц

 

нц пока не справа свободно

закрасить

вниз

кц

 

 

15.2 Решение

 

var k, n, a, amax: integer;

begin

amax:=0;

readln(n);

for k:=1 to n do

begin

readln(a);

if (a mod 5 = 0) and (a>amax) then

amax:=a;

end;

writeln(amax);

end.

 

Для проверки правильности работы программы необходимо использовать следующие тесты:

 

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая из последовательности чисел от -40 до 30 выбирает те, которые отрицательные, меняет их знак и делит на 7. построить блок-схему и написать программу, .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Natalya1895
Oksana-Kirakosyan1301
reception
соловьев_Куркина
betepah
Shevtsov1818
notka19746
Татьяна902
Мусаев Игоревич371
Сурат1199
Blekjek730
lider-mpl550
tatry2005
dkvsadovoe
teya07