kol-nat26
?>

1. написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3. написать программу, вычисляющую среднее арифметическое чисел, принадлежащих диапазону [–5; 5], среди пяти, вводимых с клавиатуры

Информатика

Ответы

tanyashevvvv
Program z1;
var a,i,sum:integer;
Begin
sum:=0;
for i:=1 to 5 do
begin;
read(a);
if (a<0) and (a mod 5=0) then
sum:=sum+a;
end;
writeln(sum);
End.

Program z2;
var a,p,i:integer;
Begin
p:=1;
for  i:= 1 to 5 do
begin;
read(a);
if (a mod 10=2) or (a mod 10=4) then
p:=p*a;
end;
writeln(p);
End.
ipaskarovanv6

Часть А

В заданиях части А выбрать только один ответ.

А1. Текстовый редактор – это приложение

1) для создания мультимедийных документов;

2) для создания, редактирования и форматирования текстовой информации;

3) для обработки изображений в процессе создания доклада.

А2. Текстовая информация-это

1) информация, представленная в форме письменного текста;

2) рисунки схемы, графики;

3) полный набор букв алфавита.

А3. Какие операции выполняют при редактировании текста?

1) Совершают операции по оформлению текста текст, исправляют ошибки, вносят изменения.

3) Выводят текст на печать.

А4. Какие из перечисленных ниже расширений соответствуют текстовому файлу?

1) exe, com, bat;

2) gif, bmp, jpg;

3) txt, doc, rtf.

А5. Какую программу нужно выбирать для обработки текстовой информации?

1) MS Excel;

2) MS Word;

3) Paint.

А6. При задании параметров страницы в текстовом редакторе устанавливаются:

1) гарнитура, начертание, размер;

2) поля, ориентация;

3) отступ, интервал.

А7. В каком из перечисленных ниже предложений правильно расставлены пробелы между словами и знаками препинания?

1) Слово не воробей , вылетит— не поймаешь!

2) Слово не воробей, вылетит — не поймаешь!

3) Слово не воробей, вылетит-не поймаешь !

4) Слово не воробей , вылетит —не поймаешь !

А8. Что такое абзац?

1) Абзац — это фрагмент текста, процесс ввода которого закончился нажатием на клавишу Esc.

2) Абзац — это фрагмент текста, процесс ввода которого закончился нажатием на клавишу Space.

3) Абзац — это фрагмент текста, процесс ввода которого закончился нажатием на клавишу Enter.

А9. К группе свойств символов можно отнести:

1) шрифт, размер шрифта, начертание и цвет;

2) выравнивание, размер шрифта, междустрочный интервал, цвет;

3) выравнивание, отступ первой строки, междустрочный интервал, отступ слева и справа, интервалы перед и после.

А10. Объем текстового файла вычисляется по формуле

1) I = K * i

2) N=2i

3) N=2*i

4) I=N+K

Так?

sancity997124
Const n=10;
var 
  a: array[1..n] of integer;
  p,k: integer;
  i: byte;
begin
  randomize;
  p:=1; k:=0;
  for i:=1 to n do begin
    a[i]:=random(21);
    if (a[i]>0) and (a[i] mod 6 =0) then begin
      p:=p*a[i];
      k:=k+1;
    end;
  end;
  println (a);
  if k>1 then writeln ('Произведение элементов, кратных 6, = ',p)  
    else if k=1 then writeln ('Найден всего 1 элемент, кратный 6, - ',p)
           else writeln ('Нет элементов, кратных 6')
end.

Примеры:

15 7 14 14 1 17 4 2 20 10
Нет элементов, кратных 6

12 11 16 1 20 6 0 8 7 20
Произведение элементов, кратных 6, = 72

14 6 8 3 15 7 14 5 19 15
Найден всего 1 элемент, кратный 6, - 6

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3. написать программу, вычисляющую среднее арифметическое чисел, принадлежащих диапазону [–5; 5], среди пяти, вводимых с клавиатуры
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

artemka56rus
Mikhailovna1444
Анна Елена
olesya-kwas
VladimirovnaSimonov
Adassa00441
ivanov568
vladimirkirv
AnvarzhonovichNadezhda1071
whitewhit90
vakhitov100961
Альберт Луиза1595
Veselova
olgakovalsky6
Akopovich802
▲