AlekseiMardanova
?>

Дано трехзначное число. составьте программу которая определяет а)кратна ли 5 сумма его первой и последней цифры б) сумма квадратов чисел в диапазоне от 1 до n в) количество натуральных чисел не превышающих 50 и кратных 3

Информатика

Ответы

sodrugestvo48
a)
Program hhh54;
var x: longint;
begin
  read (x);
  if ((x div 100) + (x mod 10)) mod 5 = 0 then write ('КРАТНА')
  else write ('НЕ КРАТНА');
end.
б)
Program hhh54;
var s,n,i: longint;
begin
  s:=0;
  read (n);
  for i:= 1 to n do
    s:=s+sqr(i);
  write (s);
end.
в)
Program hhh54;
var k,n,i: longint;
begin
  k:=0;
  for i:= 1 to 50 do
    if i mod 3 = 0 then k:=k+1;
  write (k);
end.
vse-v-sad-sdesign

Полная.

"У школы №3 1 сентября в 10:00 будет проведена линейка"


Полезная.

Состав принимаемого лекарства.

Формулы по физике во время экзамена.


Актуальная.

Курс валюты.

Погода на улице, когда вы выходите из дома.


Достоверная.

"Россия выиграла у Испании на ЧМ за счет пенальти."

Данные, записанные в документах.


Точная.

"Земля - шарообразная"


Понятная.

"Завтра на улице вас встретит сильный дождь" (вместо - "Ожидаются 50 мм осадков за 12 ч." )


Объективная.

"Высота этой скалы 100 м." (вместо "Скала довольно высокая").

moidela87
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString;
  Writeln(s.Inverse)
end.

Пример
Я пишу программу на языке Паскаль
ьлаксаП екызя ан уммаргорп ушип Я

// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Введите строку:');
  Write('Введите два символа СЛИТНО для сравнения их частоты: ');
  var ab:string;
  Readln(ab);
  var a:=ab[1];
  var b:=ab[2];
  var ka:=0;
  var kb:=0;
  for var i:=1 to s.Length do
    if s[i]=a then ka+=1
    else if s[i]=b then kb+=1;
  if ka>kb then Writeln('Символ ',a,' встречается чаще, чем ',b)
  else
    if ka<kb then Writeln('Символ ',a,' встречается реже, чем ',b)
    else
      if ka<>0 then Writeln('Символы ',a,' и ',b,' встречается одинаково')
      else Writeln('Символы ',a,' и ',b,' отсутствуют')
end.

Пример
Введите строку: а роза упала на лапу азора
Введите два символа СЛИТНО для сравнения их частоты: ао
Символ а встречается чаще, чем о

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано трехзначное число. составьте программу которая определяет а)кратна ли 5 сумма его первой и последней цифры б) сумма квадратов чисел в диапазоне от 1 до n в) количество натуральных чисел не превышающих 50 и кратных 3
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Андреевич
Galliardt Sergeevna1284
juliaydodova
konstantin0112
Ляпунов_Владмирович
pashyanaram
olartamonov6
Tatyana_Minullina
rodsher7740
coalajk
turovvlad
mail66
Vasileva
Valentina
windless-el