Nadezhda Malakhov53
?>

Меняя местами строки матрицы , отсортировать по возрастанию первый столбец (двумерный массив нужно написать программу на с++

Информатика

Ответы

os2854

#include <iostream>

int main()

{

int n;

float l;

std::cin >> n >> l;

switch (n)

{

case 1:

 std::cout << "Length: " << l / 10;

 break;

case 2:

 std::cout << "Length: " << l * 1000;

 break;

case 3:

 std::cout << "Length: " << l;

 break;

case 4:

 std::cout << "Length: " << l / 1000;

 break;

case 5:

 std::cout << "Length: " << l / 100;

 break;

default:

 break;

}

std::cout << std::endl;

system("pause");

return 0;

}

Lugovoi

1.

использовать Робот

алг 3 полоски

нач

нц пока снизу стена

закрасить

влево

кц

нц пока снизу свободно

влево

кц

нц пока слева свободно

закрасить

влево

кц

закрасить

нц пока слева стена

закрасить

вверх

кц

нц пока слева свободно

вверх

кц

нц пока слева стена

закрасить

вверх

кц

кон

2.

использовать Робот

алг

нач

нц пока сверху стена

закрасить

влево

кц

нц пока сверху свободно

влево

кц

нц пока слева свободно

закрасить

влево

кц

закрасить

нц пока слева стена

закрасить

вниз

кц

нц пока слева свободно

вниз

кц

нц пока слева стена

закрасить

вниз

кц

кон

3.

использовать Робот

алг

нач

нц пока слева стена

вверх

кц

влево

вниз

нц пока справа стена

закрасить

вниз

кц

нц пока справа свободно

вправо

кц

нц пока справа стена

закрасить

вниз

кц

кон

4.

использовать Робот

алг

нач

нц пока сверху стена

вправо

кц

вверх

нц пока слева стена

вверх

кц

влево

вниз

нц пока справа стена

вниз

кц

нц пока слева свободно

закрасить

влево

кц

кон

Объяснение: лишние циклы добавлены в случае изменений условия, а именно разной длины стенок и пропастей

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Меняя местами строки матрицы , отсортировать по возрастанию первый столбец (двумерный массив нужно написать программу на с++
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

margo929
Игоревна
vbnm100584
Алексеевич949
zsa100
andreokiseleo69421
Сумарокова
meu72
Erikhovich
thecoffeeowl
YaroslavSerganYS5
suhanowaswetlana
koam20167459
Kochinev7
alex07071