Akopovich802
?>

Написать программу, которая рассчитывает стоимость со стоимостью скидки 10% в том случае, если сумма покупки больше 1000 рублей и 20%, если cумма покупки больше 5 и 10 000 рублей. ввести стоимость покупки с учетом скидки и без ее учета.

Информатика

Ответы

vfif-804828
Var S:real;
Begin
Write('Введите сумму покупки: ');ReadLn(S);
Write('Сумма покупки с учётом скидки: ');
if S <= 1000 then WriteLn(S)
else if S > 10000 then WriteLn(S*0.8:0:2)
     else WriteLn(S*0.9:0:2);
WriteLn('Без учёта скидки: ',S:0:2);
End.
pavpe4198

Все, что мы с вами знаем, мы когда – то узнали от родителей, учителей, из книг, из личного опыта. Это информация. В свою очередь, все, что написано в книгах, журналах, газетах, отражает знание авторов этих текстов, а потому это тоже информация.

Информация для человека – это содержание получаемых им сообщений. Информация пополняет знания человека.

Учеба в школе – это целенаправленный процесс получения знаний, а значит, получения информации. Чем больше вы учитесь, тем больше информации содержит ваша память.

Восприятие информации человеком — это ознакомление с явлениями и предметами посредством их воздействия на различные органы чувств. Анализируя результат воздействия того или иного предмета или ситуации на органы зрения, слуха, обоняния, вкуса и осязания, индивид получает определенное представление о них. Таким образом, основа в процессе восприятия информации — пять наших органов чувств. При этом активно задействованы опыт человека и ранее полученные знания. Обращаясь к ним, можно отнести полученную информацию к уже известным явлениям или выделить из общей массы в отдельную категорию восприятия информации базируются на некоторых процессах, связанных с органами чувств человека:

Через зрение поступает информация в виде изображения

Через слух воспринимается информация в звуковом виде

Через обоняние воспринимается в виде запахов

Через вкус поступает информация от вкусовых ощущений

Через осязание мы получаем информацию в виде осязательных (тактильных) ощущений.

Полученную информацию человека может запомнить или записать, а также передать другому человеку.

Звуковая (отдельные буквы или сочетание букв обозначают звуки речи, а знаки препинания - паузы, интонацию)

Идеографическая (один значок обозначает слово или значительную часть слова)

Пиктографическая (рисунок, обозначающий понятие ли целое сообщение)

вот такие виды информации и восприятия человеком информацию есть

Oksana373

Все, что мы с вами знаем, мы когда – то узнали от родителей, учителей, из книг, из личного опыта. Это информация. В свою очередь, все, что написано в книгах, журналах, газетах, отражает знание авторов этих текстов, а потому это тоже информация.

Информация для человека – это содержание получаемых им сообщений. Информация пополняет знания человека.

Учеба в школе – это целенаправленный процесс получения знаний, а значит, получения информации. Чем больше вы учитесь, тем больше информации содержит ваша память.

Восприятие информации человеком — это ознакомление с явлениями и предметами посредством их воздействия на различные органы чувств. Анализируя результат воздействия того или иного предмета или ситуации на органы зрения, слуха, обоняния, вкуса и осязания, индивид получает определенное представление о них. Таким образом, основа в процессе восприятия информации — пять наших органов чувств. При этом активно задействованы опыт человека и ранее полученные знания. Обращаясь к ним, можно отнести полученную информацию к уже известным явлениям или выделить из общей массы в отдельную категорию восприятия информации базируются на некоторых процессах, связанных с органами чувств человека:

Через зрение поступает информация в виде изображения

Через слух воспринимается информация в звуковом виде

Через обоняние воспринимается в виде запахов

Через вкус поступает информация от вкусовых ощущений

Через осязание мы получаем информацию в виде осязательных (тактильных) ощущений.

Полученную информацию человека может запомнить или записать, а также передать другому человеку.

Звуковая (отдельные буквы или сочетание букв обозначают звуки речи, а знаки препинания - паузы, интонацию)

Идеографическая (один значок обозначает слово или значительную часть слова)

Пиктографическая (рисунок, обозначающий понятие ли целое сообщение)

вот такие виды информации и восприятия человеком информацию есть

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая рассчитывает стоимость со стоимостью скидки 10% в том случае, если сумма покупки больше 1000 рублей и 20%, если cумма покупки больше 5 и 10 000 рублей. ввести стоимость покупки с учетом скидки и без ее учета.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vahmistrova
VadimovnaIgor
MN-Natusik80
Nikolaevich_Vladimirovich1509
serkan777
elenakarpova709
inj-anastasia8
Александрович686
ramco1972
zvanton
Sidunevgeniya
Anastasiya1537
eizmaylova6
cristiansirbu9974
info32
▲