Azarova Anastasiya1707
?>

Вводится массив, состоящий из целых чисел. определите, сколько из них положительные. входные данные сначала задано число n — количество элементов в массиве (1≤n≤35 далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. выходные данные необходимо вывести одно целое число — количество положительных элементов массива. примеры ввод вывод 3 1 -2 0 1

Информатика

Ответы

OOO"Kiprei"_Aleksandr1938
Program n1;
var n, k, i, c : integer; a:array[0..35] of integer;
begin
  read(N);
  if (N>=1)and(N<=35) then c:=n
  else
    begin
      writeln('error');
      read(N);
    end;
  for i:=1 to c do
    begin
      read(a[i]);
      if A[i]>0 then k:=k+1;
    end;
  writeln(k);
end.

Как то так
программа была скопирована из компилятора и там работала по условию
Karlova1507
Программа:
#include <iostream>
using namespace std; 
int main()
{
    int a=5;
    int b=4;
    int c;
    cout << "Количество яблок у Васи = " << a << "\n";
    cout << "Количество яблок у Пети = " << b << "\n";
    cout << "Количество яблок у Васи и Пети вместе = " << a+b << "\n";
    c=(a+b)/3;
    cout << "Если разделить на 3-х поровну, то получится = " << c << "\n";
    return 0;
}

Результат:
Количество яблок у Васи = 5
Количество яблок у Пети = 4
Количество яблок у Васи и Пети вместе = 9
Если разделить на 3-х поровну, то получится = 3
sveta1308
1. При использовании палитры из 2^24 цветов для хранения цвета 1 пикселя используется 24 бита = 3 байта.
Пусть количество пикселей в рисунке K, тогда объем памяти, занимаемой одним рисунком = (K*3)/1024 + 128 Кбайт.
X = 8*(K*3/1024 + 128)+2.5*1024
2. При использовании палитры из 2^16 цветов для хранения цвета 1 пикселя используется 16 бита = 2 байта.
Объем памяти, занимаемой одним рисунком = (K*2)/1024 + 128 Кбайт.
X = 20*(K*2/1024 + 128)
8*(K*3/1024 + 128)+2.5*1024 = 20*(K*2/1024 + 128)
К = 65536 (количество пикселей в рисунке)
X = 20*(K*2/1024 + 128) = 20*(65536*2/1024 + 128) Кбайт = 
 20*(128 + 128) Кбайт = 5120 Кбайт = 5120/1024 Мбайт = 5 Мбайт

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вводится массив, состоящий из целых чисел. определите, сколько из них положительные. входные данные сначала задано число n — количество элементов в массиве (1≤n≤35 далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. выходные данные необходимо вывести одно целое число — количество положительных элементов массива. примеры ввод вывод 3 1 -2 0 1
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Оксана Николаевич
horst58
Latsukirina
kononova_Pavel689
mariyachervonnaya44
aninepp
verav75
Ваган Шутова332
beaevgen711
imosal
dovgash2
sadinuraliev263
ksoboleva
udalova-yelena
vladimyrgorbunov