Артур
?>

С++ (в применить операторы цикла) 1. написать программу, которая выводит таблицу значений функции у = -2.4*x2+5*x-3 в диапазоне от -2 до 2, с шагом 0.5. 2. часы бьют каждый час, столько раз, сколько времени. написать программу, которая подсчитает, сколько раз пробьют часы за n часов. n – задает пользователь. (часы считать от 0 часов до 24) 3. пользователь открыл счет в банке и положил 1 000 000 грн. под 8% годовых. каждый год он снимает 100 000 грн. выполнить: а) на экран выводить по каждому году; б) рассчитать, через сколько лет деньги на счету закончатся. (в применить операторы цикла)

Информатика

Ответы

Aleksandr556
#include <iostream>
using namespace std;
int main()
{
    float x = -2;
    do
    {
    cout<<"y("<<x<<") = "<<(-2.4*x*x+5*x-3)<<"\n";
    x+=0.5;
    }
    while(x <= 2);
    return 0;
}

#include <iostream>
using namespace std;

int main()
{
    int N;
    double S = 0;
    cout <<"N = ", cin >> N;
    for(int i = 0; i < N; i++)
        S+=i%24;
    cout <<"S = "<<S;
    return 0;
}

#include <iostream>
using namespace std;

int main()
{
    double S = 1000000;
    int L = 0;
    do
    {
        S*=1.08;
        S-=100000;
        cout<<L<<": "<<S<<'\n';
        L++;
    }while(S > 0);
    cout <<"Kol-vo let = "<<L;
    return 0;
}
drontox1031

Смотрите объяснение

Объяснение:

использовать Чертежник

алг

нач

поднять перо

сместиться в точку(2,5)

опустить перо

сместиться на вектор(2,0)

сместиться на вектор(4,0)

сместиться на вектор(0,10)

сместиться на вектор(5,10)

сместиться на вектор(9,0)

сместиться на вектор(11,0)

сместиться на вектор(2,-4)

сместиться на вектор(0,-4)

сместиться на вектор(0,-5)

сместиться на вектор(-4,0)

сместиться на вектор(0,-7)

сместиться на вектор(2,0)

сместиться на вектор(4,0)

сместиться на вектор(2,0)

сместиться на вектор(0,5)

сместиться на вектор(0,15)

сместиться на вектор(0,5)

сместиться на вектор(0,5)

сместиться на вектор(2,3)

сместиться на вектор(-2,0)

сместиться на вектор(-2,0)

сместиться на вектор(-2,-2)

сместиться на вектор(0,-4)

сместиться на вектор(0,-2)

сместиться на вектор(3,-2)

сместиться на вектор(-4,2)

сместиться на вектор(-4,2)

сместиться на вектор(-4,0)

сместиться на вектор(-4,0)

сместиться на вектор(-4,0)

сместиться на вектор(-2,0)

сместиться на вектор(-2,0)

сместиться на вектор(-1,0)

сместиться на вектор(-1,0)

сместиться на вектор(-4,-4)

сместиться на вектор(0,5)

сместиться на вектор(0,6)

сместиться на вектор(-2,-4)

сместиться на вектор(-2,0)

сместиться на вектор(-2,0)

сместиться на вектор(-2,0)

сместиться на вектор(-2,0)

сместиться на вектор(-2,2)

сместиться на вектор(0,-5)

сместиться на вектор(0,-5)

сместиться на вектор(5,-1)

сместиться на вектор(5,1)

сместиться на вектор(2,1)

сместиться на вектор(-5,-5)

сместиться на вектор(0,-10)

сместиться на вектор(0,-2)

сместиться на вектор(-2,0)

сместиться на вектор(-2,0)

сместиться на вектор(0,-5)

сместиться на вектор(0,-1)

сместиться на вектор(3,0)

опустить перо

сместиться на вектор(4,0)

поднять перо

сместиться на вектор(-6,0)

сместиться на вектор(-1,0)

сместиться на вектор(0,5)

сместиться на вектор(0,1)

сместиться на вектор(4,0)

сместиться на вектор(0,12)

сместиться на вектор(4,5)

сместиться на вектор(-2,0)

опустить перо

сместиться на вектор(-2,0)

сместиться на вектор(-2,0)

сместиться на вектор(-2,0)

сместиться на вектор(3,0)

сместиться на вектор(0,2)

поднять перо

сместиться на вектор(2,0)

опустить перо

сместиться на вектор(0,3)

поднять перо

сместиться на вектор(-4,0)

опустить перо

сместиться на вектор(0,-3)  

кон


Выбирайте любой рисунок!​
rukodelnizza1
Программа:
const
  n = 5;
  m = 5;
 
var
  a: array[1..n, 1..m] of integer;
  i, j: integer;
 
function check(i: integer): boolean;
var j: integer;
begin
  check := false;
  j := 0;
  repeat
    inc(j);
    if a[i, j] < 0 then
    begin
      check := true;
      exit;
    end;
  until j = m;
end;
 
function search: integer;
var i: integer;
begin
  search := 0;
  i := 0;
  repeat
    inc(i);
    if not(check(i)) then
    begin
      search := i;
      exit;
    end;
  until i = n;
end;
 
begin
  writeln('Введите матрицу ', n, 'x', m,': ');
  i := 0;
  repeat
    j := 0;
    inc(i);
    repeat
      inc(j);
      read(a[i, j]);
    until j = m;
  until i = n;
  writeln('ответ: ', search);
end.
Пример работы программы:
Введите матрицу 5x5:
3 4 2 3 -2
3 -5 -7 -2 1
8 2 5 4 -4
0 1 2 3 4
1 7 2 -5 2
ответ: 4
* Примечание: Если во всех строках есть отрицательные элементы, то ответ будет 0 (можно изменить в самой процедуре)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

С++ (в применить операторы цикла) 1. написать программу, которая выводит таблицу значений функции у = -2.4*x2+5*x-3 в диапазоне от -2 до 2, с шагом 0.5. 2. часы бьют каждый час, столько раз, сколько времени. написать программу, которая подсчитает, сколько раз пробьют часы за n часов. n – задает пользователь. (часы считать от 0 часов до 24) 3. пользователь открыл счет в банке и положил 1 000 000 грн. под 8% годовых. каждый год он снимает 100 000 грн. выполнить: а) на экран выводить по каждому году; б) рассчитать, через сколько лет деньги на счету закончатся. (в применить операторы цикла)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

алексей-Ветошкин
asyaurkova
serkan777
Larisa-0888716
kolgatin69
badalovao256
muz-cd
mshelen732
okarp
kagurkina
maxchuev
adman7
Ivan1568
osnovnoisklad3551
AntonovaAvi1716
▲