yurazharov
?>

Склавиатуры задаётся трёхзначное число. составить программу, которая определяет, есть ли среди цифр этого числа нечётные

Информатика

Ответы

drappaeva68
Var
   A:integer;
Begin
Write('Введите трёхзначное число: ');ReadLn(A);
if ((A div 100) mod 2 = 0)or(((A div 10) mod 10) mod 2 = 0)or(A mod 2 = 0) then WriteLn('Есть')
else WriteLn('Нет')
End.
leonidbaryshev19623

16

Объяснение:

1. Алфавит мощностью 26 символов требует для кодирования символа 5 бит (2⁴ < 26 < 2⁵). 22 символа займут 22×5 = 110 бит = 110 / 8 = 13.75 байта, округляем до целого вверх, получаем 14 байт.

2. Номер года обозначается одним из 100 чисел. 2⁶ < 100 > 2⁷, поэтому для кодирования требуется 7 бит.

3. Номер для обозначается одним из 366 чисел. 2⁸ < 366 > 2⁹, поэтому для кодирования требуется 9 бит.

4. Всего для кодирования срока действия потребуется 7+9 = 16 бит = 16/2 = 2 байта

5. Вся информация на пропуске займет 14+2 = 16 байт

Алла14

16

Объяснение:

1. Алфавит мощностью 26 символов требует для кодирования символа 5 бит (2⁴ < 26 < 2⁵). 22 символа займут 22×5 = 110 бит = 110 / 8 = 13.75 байта, округляем до целого вверх, получаем 14 байт.

2. Номер года обозначается одним из 100 чисел. 2⁶ < 100 > 2⁷, поэтому для кодирования требуется 7 бит.

3. Номер для обозначается одним из 366 чисел. 2⁸ < 366 > 2⁹, поэтому для кодирования требуется 9 бит.

4. Всего для кодирования срока действия потребуется 7+9 = 16 бит = 16/2 = 2 байта

5. Вся информация на пропуске займет 14+2 = 16 байт

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Склавиатуры задаётся трёхзначное число. составить программу, которая определяет, есть ли среди цифр этого числа нечётные
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Константин Андрей
elenarumack
sveta740450
Пономаренко
genya1509
Urmanov19903131
Хохлов
elenasnikitina84
skvik71672
janepustu
zakupki
taanaami75
ЕкатеринаРустам
Yanusik24
len4ik1986