Иванникова736
?>

На целочисленной прямой произвольно заданы четыре точки a, b, c, d. определите, сколько целых чисел принадлежат одновременно отрезку ab и отрезку cd. написать программу в паскале

Информатика

Ответы

Качкова1820
// PascalABC.NET 3.2, сборка 1485 от 15.06.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a,b,c,d:integer;
  Write('Введите через пробел значения a,b,c,d: ');
  Read(a,b,c,d);
  if a>b then Swap(a,b); if c>d then Swap(c,d);
  var ab:=Range(a,b); var cd:=Range(c,d);
  var n:=ab.Intersect(cd).Count;
  Write('Количество целых чисел равно ',n)
end.

Пример
Введите через пробел значения a,b,c,d: 3 10 12 5
Количество целых чисел равно 6
steff77
Какие значения чисел:
0.85Е2 =85
-5.7Е-3 = -0.0057
0.1Е4=1000

Что будет выведено на экран после выполнения следующих команд:
a-435c
c=    35.1b=   -435  280.126-435

Вычислить значения выражений:
Round(frac(6.9)); = 1
20 mod 6 * 3; = 6
sqrt(trunc(0.5)) = 0

Записать выражения в общепринятой форме:
(-3ab+(b-4*a*c)^2)/корень(2*a);
(корень(|a-b|)*(a+b)^2.

a) y:= y * 2; правильная. операция возможна для вещественных чисел.
в) х:= х mod 3 + х*cos(0); правильная, все опрации подходят для целых чисел
б) x:=trunc(y); правильная
г) x:= y+1. неверно нельзя преобразовать вещественный тип в целый
Guru-tailor

1. Расчертить все поле горизонтальными пунктирными линиями.

НАЧ

ПОКА впереди НЕ стена

НЦ

ДЕЛАЙ линия

ДЕЛАЙ правый переход

ДЕЛАЙ линия

ДЕЛАЙ левый переход

КЦ

КОН

ПРОЦЕДУРА линия

ПОКА впереди НЕ стена

НЦ

ШАГ

ЕСЛИ впереди НЕ стена

ТО

ПРЫЖОК

ВСЁ

КЦ

КОНЕЦ ПРОЦЕДУРЫ

ПРОЦЕДУРА правый переход

ПОВОРОТ

ПОВОРОТ

ПОВОРОТ

ЕСЛИ впереди НЕ стена

ТО

ПРЫЖОК

ПОВОРОТ

ПОВОРОТ

ПОВОРОТ

ВСЁ

КОНЕЦ ПРОЦЕДУРЫ

ПРОЦЕДУРА левый переход

ПОВОРОТ

ЕСЛИ впереди НЕ стена

ТО

ПРЫЖОК

ПОВОРОТ

ВСЁ

КОНЕЦ ПРОЦЕДУРЫ

2) Нарисовать квадраты во всех углах поля.

НАЧ

ДЕЛАЙ квадрат

ДЕЛАЙ переход

ДЕЛАЙ квадрат

ДЕЛАЙ переход

ДЕЛАЙ квадрат

ДЕЛАЙ переход

ДЕЛАЙ квадрат

КОН

ПРОЦЕДУРА квадрат

ШАГ

ПОВОРОТ

ПОВОРОТ

ПОВОРОТ

ШАГ

ПОВОРОТ

ПОВОРОТ

ПОВОРОТ

ШАГ

ПОВОРОТ

ПОВОРОТ

ПОВОРОТ

ШАГ

ПОВОРОТ

ПОВОРОТ

ПОВОРОТ

КОНЕЦ ПРОЦЕДУРЫ

ПРОЦЕДУРА переход

ПОКА впереди НЕ стена

НЦ

ПРЫЖОК

КЦ

ПОВОРОТ

ПОВОРОТ

ПОВОРОТ

КОНЕЦ ПРОЦЕДУРЫ


Что такое пошаговая детализация? из каких команд могут состоять алгоритмы последнего уровня детализ
Что такое пошаговая детализация? из каких команд могут состоять алгоритмы последнего уровня детализ

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На целочисленной прямой произвольно заданы четыре точки a, b, c, d. определите, сколько целых чисел принадлежат одновременно отрезку ab и отрезку cd. написать программу в паскале
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Zhilinoe134
Shipoopi8
TrofimovAnastasiya828
Валерия Воробьева396
dddddd68
nat5555
elenaperemena8
Александрович Владимирович
fudan
vanvangog199826
maestro6838
sgritsaev
rimmaskis
igevskoemuseumkec
rimmatrotskaia303