ribcage52
?>

Известны результаты каждой из 4-х четвертей баскетбольной встречи. Необходимо составить программу, которая определяет победителя матча, а также определяет четверть с максимальной разницей очков. (паскаль)​

Информатика

Ответы

Daniil1945

const

  n = 3;

  m = 4;

var

  matrix: array[1..n, 1..m] of integer;

  max, max_i, max_j, i, j: integer;

  sum: integer;

 

begin

  writeln('введите массив ',n, '*', m, ' элементов: ');

  for i : = 1 to n do

    for j : = 1 to m do

      read(matrix[i,j]);

     

  max : = matrix[1,1];

 

  for i : = 1 to n do

    for j : = 1 to m do

      if (max < matrix[i,j]) then

      begin

        max : = matrix[i,j];

        max_i : = i;

        max_j : = j;

      end;

 

  sum : = 0;

 

  for i : = 1 to n do

    sum : = sum + matrix[i, max_j];

   

  for j : = 1 to m do

    sum : = sum + matrix[max_i, j];

   

  matrix[max_i, max_j] : = sum;

 

  writeln('получившийся массив: ');

  for i : = 1 to n do

  begin

    for j : = 1 to m do

      write(matrix[i,j], ' ');

   

    writeln();

  end;

end.

пример:

введите массив 3*4 элементов:

1 2 3 4

55 6 7 8

9 10 11 12

получившийся массив:

1 2 3 4

141 6 7 8

9 10 11 12

vsnimschikov391

nomer3

program ab;

uses crt

uses sysutils;

var s,s1: string;

i,j: integer;

begin

clrscr;

write('введите строку слово');

writeln;

readln(s);

for i: =1 to length(s) do

for j: =1 to length(s) do

if (s[i]=s[j]) and(i< > j)

then

if pos(s[i], s1)=0

then s1: =s1+s[i]+' ';

write('повторяющиеся символы: ', s1);

readln;

end.

nomer2

program as

uses crt;

var s,sp: string;

i: integer;

begin

clrscr;

write('s=');

readln(s);

sp: ='';

for i: =1 to length(s) do

sp: =s[i]+sp;

if sp=s then writeln ('палиндром')

else writeln ('не палиндром');

readkey

end.

nomer1

function compare(s1,s2: string): boolean;

begin

result: =s1=s2;

end;

var s1,s2: string;

begin

readln(s1);

readln(s2);

if compare(s1,s2) then write('yes')

else write('no')

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Известны результаты каждой из 4-х четвертей баскетбольной встречи. Необходимо составить программу, которая определяет победителя матча, а также определяет четверть с максимальной разницей очков. (паскаль)​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

maruska90
scraer198258
os7960
Хромов1501
info9
Виктория Нина
gernovoy
kirill81
Вера1072
taa19707470
AnastasiyaSkripin1283
ksen1280
snezhanaklimenkova
Артур1807
nopel91668
▲