marinakovyakhova
?>

Составить программу на языке кумир по трем введенным сторонам надо сказать возможно ли существование такого треугольника и если да, то какой он: разносторонний, равносторонний или равнобедренный

Информатика

Ответы

cristiansirbu9974
Алг
нач
  вещ а, б, в
  вывод "Введите длины сторон треугольника: "
  ввод а, б, в
  вывод "Данный треугольник абв "
  если (а < б + в)и(б < в + а)и(в < а + б) то
      если (а = б)и(б <> в)или(б = в)и(в <> а)или(в = а)и(а <> б)
        то вывод "равнобедренный"
        иначе
          если а = б и б = в
            то вывод "равносторонний"
            иначе вывод "разносторонний"
          всё
       всё
     иначе вывод "не существует"
  всё
кон
Vladimir1172
1 - моделью
2 - меньше информации
3 - глобус, макет здания, муляж яблока, манекен
4 - рисунок, фотография
5 - знаковой
6 - смешанной
7 - автомобиль — техническое описание автомобиля, город — путеводитель по городу
8 - существенные признаки объекта-оригинала
9 - разные модели объекта
10 - физическая карта, график зависимости расстояния от времени, схема узора для вязания крючком, схема метро
11 - словесное описание, формула
12 - знаковой
13 - смешанной
14 - болт — чертеж болта, мелодия — нотная запись мелодии
Кирилл_Гульницкий
Четное число делится на два, а кратное пяти делится на пять, поэтому число должно делиться без остатка на 2х5=10

// PascalABC.NET 3.0,сборка 1076
begin
  var n:=ReadInteger('Длина последовательности: ');
  var a:=ArrRandom(n,-50,50);
  Writeln('Исходная последовательность');
  a.Println;
  Writeln('Сумма элементов: ',a.Sum);
  Write('Кол-во четных, кратных пяти: ');
  Writeln(a.Where(x-> x mod 10 = 0).Count)
end.

Тестовое решение:
Длина последовательности: 20
Исходная последовательность
-4 21 -21 -23 14 -39 -12 1 -7 4 17 -45 30 -48 -19 -12 27 -46 -37 15
Сумма элементов: -184
Кол-во четных, кратных пяти: 1

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу на языке кумир по трем введенным сторонам надо сказать возможно ли существование такого треугольника и если да, то какой он: разносторонний, равносторонний или равнобедренный
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

turoverova5
Dmitriy2211104
best00
Бочкарева Горохова1652
Nadirovich1317
yelena
MariyaKhanbalaeva585
npprang21
Владислав-Аветисян217
Galinagol559
Исаченко Тераски1181
zrs-546
Максим_Нина
Дмитрий192
toxicfish