Татьяна_Полулях
?>

Дан рост трех друзей. как написать программу которая определяет их среднийрост на языке pascalabc?

Информатика

Ответы

insan10

var

a,b,c: real;

begin

readln(a,b,c);

writeln((a+b+c)/3);

end.

БашуроваОльга369
#include < cstdlib> #include < ctime>   #include < iostream> using namespace std; int main() {     int n=10, i, s=0;     int a[n];     srand(time(null));     cout< < "array: "< < endl;     for (i=0; i< n; i++)     {       a[i]=rand() % 50;       cout< < a[i]< < "  ";     }     cout< < endl;           i = 1;     do {     a[i] = a[i]*a[i];     s += a[i];     i += 2;     } while (i< =n);           for (i=0; i< n; i++) cout< < a[i]< < " ";     cout< < endl;     cout < < "s = " < < s < < endl;     return(0); } пример: array: 39 10 25 35 9 14 29 34 24 4139 100 25 1225 9 196 29 1156 24 1681s = 4358
Никитина580
#include < iostream> #include < cstdlib> #include < ctime> using namespace std; int main() { srand(time(0)); const int n = 5; int x[n], y[n], x0=0, y0=0; for (int i = 0; i < n; ++i) { x[i] = rand() % 5; y[i] = rand() % 5; } for (int i = 0; i < n; ++i) { cout< < x[i]< < ' '; } cout < < endl; for (int i = 0; i < n; ++i) {cout < < y[i] < < ' '; } for (int i = 0; i < n; ++i) { if (x[i]) x0++; if (y[i]) y0++; } cout < < endl; if (x0 > y0) cout < < 'x'; if (x0 < y0) cout < < 'y'; if (x0 == y0) cout < < '=';   return 0; }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дан рост трех друзей. как написать программу которая определяет их среднийрост на языке pascalabc?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Григорьевич915
energycomplect5914
Дмитрий-Олейникова
Leonidovich_Elena771
Nikolai710
tigran87-87
imosal
Сурат1199
Liliya-buc
verkop9
Aleksei1463
Amulenkov
gumirovane2294
Акимцева27
tarhan1221