Program Pr1;
uses crt;
var fl1,fl2:text;
i,n,v,a,b:integer;
Begin
clrscr;
assign(fl1,'input.txt');
assign(fl2,'output.txt');
reset(fl1);
readln(fl1,n);
v:=0;
for i:=1 to 1000000 do begin
if i>=10 then begin
a:=i div 10;
b:=i mod 10;
if (a mod 2<>0) and (b mod 2<>0) then v:=v{?} 1; {здесь либо пропущен знак либо v1-новая переменная не перечисленная в списке описания переменных}
end
else if i mod 2<>0 then v:=v 1;{здесь тоже самое}
if v=n then break;
end;
rewrite(fl2);
writeln(fl2,v);
close(fl1);
close(fl2);
end.
Числовая информация - данные, выраженные в виде специальных символов - цифр, чисел. Необходима для, например экономических взаимоотношений. Пример такой информации - ценники в магазинах, данные различных приборов, и пр.
текстовая информация - это перенос речи, мыслей, рассуждений в форму текста - сочетания букв, причем различные языки имеют свой набор символов. Пример такой информации - книги, различные документы, протоколы и пр.
графическая информация - самый, наверное, древний отображения и передачи информации. Это - различные изображения. Примеры - наскальная живопись, фрески, картины, диаграммы, чертежи, схемы и пр.
звуковая - информация, в основе которой лежат звуковые колебания. Так же - один из древнейших видов. Примеры - человеческая речь, музыка, различного рода сигнализация и пр.
Видеоинформация - информация, хранящаяся в таком формате, что при воспроизведении ее происходит передача с изменением объекта во времени, информация сменяется информацией - графические объекты "движутся". Пример видеоинформации - кино, телевидение, компьютерные игры и пр...
Поделитесь своими знаниями, ответьте на вопрос:
Входные данные:
В первой строке вводится целое положительное число
Выходные данные:
В единственной строке выходного файла вывести произведение всех элементов массива
Пример ввода:
3
1 2 3
Пример вывода:
3
Писал на: PascalABC.Net v.3.2, сборка 1325 (19.10.2016)
Исходный код решения находится в приложении №1.
2.
Входные данные:
В первой строке вводится целое положительное число
Выходные данные:
В единственной строке выходного файла вывести сумму всех элементов массива
Пример ввода:
3
1 2 3
Пример вывода:
2
Писал на: PascalABC.Net v.3.2, сборка 1325 (19.10.2016)
Исходный код решения находится в приложении №2.