sadinuraliev263
?>

Назовем число палиндром, если оно не меняется при перестановке его цифр в обратно порядке. напишите программу, которая по заданному числу к выводит количество натуральных палиндромом, не превосходящих к.

Информатика

Ответы

annanudehead1426

ответ:

{l-левая половинка числа, r - правая}

var count,k,m,r,l: longint;

begin

  count: =0; writeln('введите k');   readln(k);

  for l: =1 to k do

  begin

      r: =0; m: =l;

      while m> 0 do

      begin

          r: =r*10+m mod 10;

          m: =m div 10;

      end;

      if r=l then count: =count+1;

  end;

  writeln(count);

Kisuha8465
(18 чисел)                                                                                                                     101,102,103,120,130,123,132,201,203,230,213,210,301,302,320,312,321,310.
Kamil
1) 1000000
ответ:1
2)44100*60*2*24=127008000 бит = 15876000 байт = 15503 Кб
3) пусть время х. тогда:
1/3*х * 60 + 2/3*х * 90 = 27000
20х + 60х = 27000
8х=2700
х=337 секунд
4)102 + 108 +1016 = 1226 = 10011001010(2)
5)???
6)128*16=2048 пикселей
512/2048 = 1/4 байта/пиксель = 2 бита/пиксель
2^2 = 4
ответ: 4 цвета
7)256 = 2^8 -> 8 бит/пиксель = 1 байт/пиксель
256*512*1=131072 байт = 128 Кб
8)128 Тбайт = 128 * 1024 * 1024 * 1024 * 1024 * 8 бит = 1125899906842624 бит
9)???
10) 1024 = 2^10
10*60*48000*10 = 288000000 бит = 35156 Кбайт
11)  16*32*64*16 = 524288 бит = 64 Кбайт
12) 44 символа * 1 байт/символ = 44 байта
13)??? (ничего не подходит под первый символ)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Назовем число палиндром, если оно не меняется при перестановке его цифр в обратно порядке. напишите программу, которая по заданному числу к выводит количество натуральных палиндромом, не превосходящих к.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Leon-12
elenaneretina
arbat
Alyona744
info2990
avon-central
sarbaevmax
AlekseiMardanova
Fedorov1283
TrubnikovKlimenok926
Yurevich1701
Евгеньевич Балиловна1398
foto5113161
artem
soa8690