Anton-Yurevich222
?>

Определите, является ли не более чем четырехзначное число k симметричным (например, 1331 или 0550 на вход программе подается целое число k (0 k 9999). выдайте 1 при положительном ответе на вопрос и любое другое целое число — в противном случае.

Информатика

Ответы

mskatrinmadness
Var
a:integer;
begin
readln(a);
If (a<10000) and (a>=0) then
If (a>999) then
If ((a div 1000)=(a mod 10)) and ((a div 10 mod 10)=(a div 100 mod 10)) then
writeln('1')
else
writeln('2')
else
If (a>99) and (a<1000) then
If ((a div 100)=(a mod 10)) then
writeln('1')
else
writeln('2')
else
If (a>9) and (a<100) then
If ((a div 10)=(a mod 10)) then
writeln('1')
else
writeln('2')
else
writeln('1')
else
writeln('Неправльное число');
end.
Большое немного решение, может можно и поменьше, но так точно правильно
inulikb
Клод Шеннон, был такой Американский инженер и математик, его работы являются синтезом математических идей с конкретным анализом чрезвычайно сложных проблем их технической реализации
Он является основателем теории информации, нашедшей применение в современных высокотехнологических системах связи. Шеннон внес огромный вклад в теорию вероятностных схем, теорию автоматов и теорию систем управления — области наук, входящие в понятие «кибернетика». В 1948 году предложил использовать слово «бит» для обозначения наименьшей единицы информации (в статье «Математическая теория связи»).
mstapottery
Программа посимвольно читает стандартный ввод (клавиатура) и выбирает только цифры - все остальное игнорируется. Как результат, получает последовательность из натуральных чисел. Для завершения ввода нужно ввести "0". Любые символы после 0 считаны не будут.
\\\\\\\\\\\\\\\\\\\
using System;
namespace sequen {
    class Program {
        static string seq() {
            string res = "";
            char symb;
            while ((symb = (char)Console.Read()) != ' ' && symb != '\n') {
                if (symb >= '0' && symb <= '9')
                    res += symb.ToString();
            }
            if (res == "") return seq(); //Если ни один символ не подошел
            if (res != "0") return seq() + res + " "; // Если число считано
            else return ""; // Если конец
        }
        static void Main(string[] args) {
            Console.Write("Введите последовательность: ");
            Console.WriteLine("Результат: {0}", seq());
            Console.ReadKey();
        }
    }
}
Написать рекурсивную процедуру для ввода с клавиатуры последовательности чисел(окончание ввода-0) и

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Определите, является ли не более чем четырехзначное число k симметричным (например, 1331 или 0550 на вход программе подается целое число k (0 k 9999). выдайте 1 при положительном ответе на вопрос и любое другое целое число — в противном случае.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sokolskiy458
ivanpetrovichru1801
Витальевна
kayrina
prostopo4ta29
Викторовна
Artyukhin545
stertumasova29
Шарабанов
Shlapakov1911aa
Karmelita1978
Андрей Анна22
far-yuliya128
Fedorovna
ninakucherowa
▲