admin8808
?>

Язык c#. написать программу на языке c#разветвляющейся структуры согласно вариантам 1 (используя if) и 2 (используя switch) . 1.даны два числа. большее из этих двух чисел заменить их полусуммой, а меньшее удвоенным произведением. 2.2. вводится число экзаменов n< =20. напечатать фразу "мы успешно сдали n экзаменов", согласовав слово "экзамен" с числом n.

Информатика

Ответы

Екатерина
1.
using System;

class Program
{
public static void Main()
{
         double x,y,s,p;
         Console.Write("x = ");
         x = double.Parse(Console.ReadLine());
         Console.Write("y = ");
         y = double.Parse(Console.ReadLine());
         s = (x+y)/2;
         p = 2*x*y;
         if (x>y){
          x = p;
          y = s;
         }
         else {
          y = p;
          x = s;
         }
        Console.WriteLine("x = {0}, y = {1}", x, y);
        Console.ReadKey();
}
}

Пример:
x = 2.4
y = 8.3
x = 5.35, y = 39.84

2.
using System;

public class Test
{
public static void Main()
{
int n;
Console.Write("n = ");
n = int.Parse(Console.ReadLine());
switch (n){
case 1:
Console.WriteLine("Мы успешно сдали {0} экзамен", n);
break;
case 2:
case 3:
case 4:
Console.WriteLine("Мы успешно сдали {0} экзамена", n);
break;
default:
Console.WriteLine("Мы успешно сдали {0} экзаменов", n);
break;
}
}
}

Пример:
n = 6
Мы успешно сдали 6 экзаменов
Иванов1813
1) собирается - журналист опрашивает людей для статьи
2) обрабатывается - ученик решает уравнение
2) упрощается - преподователь объясняет материал 
3) создается - журналист придумывает статью
4) запоминается - парнень запоминает номер телефона девушки
5) измеряется - программист рассчитывает сколько бит займет 
программа
6) копируется - ученик списывает у одноклассника
7) передается - две девушки обмениваются новостями
8) принимается - ученики слушают учителя на уроке
9) разрушается - статья журналиста отвергается
10) делится на части - человек разбирает сообщение в котором 
пропущены пробелы
11) ищется - человек ищет материал для реферата в интернете
Nasteona1994
1. Внутреннюю — оперативную и внеш¬нюю — долговременную
2. Управление устройствами и задачами
3. Красный, зеленый, синий
4. Целые числа в памяти компьюте¬ра это:
Дискретное и конечное множество
5. Контроллер
6. Передача данных, передача адресов

7. D

8. Прикладные программы общего назначения и специализированные программы
9. Главная формула информатики?
2i = N
16i = N
2f = Z
2i = M

10. Прикладные программы и системные программы

11. К основным типам устройств оперативной памяти относятся?
Динамическая и статическая память
12. Компьютер
13. Какой универсальный звуко¬вой формат файлов используется для сохранения звука без потерь?
WAV

14. Множество целых чисел в компьютере дискретно, конечно, ограничено

15. В памяти компьютера числа хранятся?
В двоичной сис¬теме счисления

16. Архитектура персонального компьютера это?
Общие принципы построения компьютера

17. Как называется инструмент для работы профессиональных программистов?
Многопользовательские и многозадачные системы программирования

18. Какой термин считается правильным о представлении о множестве целых чисел в математике?
Множество целых чисел дискретно, бесконечно, неограниченно

19. Текстовая информация уже дискретна и состоит из?
Отдельных знаков

20. Какую графику применяют при разработке электронных и полиграфических изданий?
Векторная

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Язык c#. написать программу на языке c#разветвляющейся структуры согласно вариантам 1 (используя if) и 2 (используя switch) . 1.даны два числа. большее из этих двух чисел заменить их полусуммой, а меньшее удвоенным произведением. 2.2. вводится число экзаменов n< =20. напечатать фразу "мы успешно сдали n экзаменов", согласовав слово "экзамен" с числом n.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

nairahay
sttig
os7960
bsi771184
modos201276
skvorec3424
annakorolkova79
ViktorovnaLarin
Владимирович_Ралина
pucha5261
Yurok9872
vallium8354
dimalihachew
yurogov61
Корягина