Sergei-Gradus199
?>

Nшкольников делят k яблок поровну, неделяющийся остаток остается в корзинке. сколько яблок достанется каждому школьнику? входные данные программа получает на вход числа n и k - целые, положительные, не превышают 10000. нужно записать на языке программирования питон(python)

Информатика

Ответы

Александрович Андреевна
N = int(input())
k = int(input())
print('Число яблок у каждого школьника - ',k//n)

Пример:
4
15
Число яблок у каждого школьника - 3
Vladimirovich351
Иерархическая БДИерархические базы данных — самая ранняя модель представления сложной структуры данных. Информация в иерархической базе организована по принципу древовидной структуры, в виде отношений «предок-потомок». Каждая запись может иметь не более одной родительской записи и несколько подчиненных. Связи записей реализуются в виде физических указателей с одной записи на другую. Основной недостаток иерархической структуры базы данных — невозможность реализовать отношения «много-ко-многим», а также ситуации, когда запись имеет несколько предков. Графически такую структуру можно изобразить в виде дерева, состоящего из объектов различных уровней. Верхний уровень занимает один объект, второй — объекты второго уровня и так далее. Между объектами существуют связи, каждый объект может включать в себя несколько объектов более низкого уровня. Такие объекты находятся в отношении предка (объект более близкий к корню) к потомку (объект более низкого уровня), при этом возможно, чтобы объект-предок не имел потомков или имел их несколько, тогда как у объекта-потомка обязательно только один предок. Объекты, имеющие общего предка, называются близнецами.
Ioanova Korneeva1093
2)// bu_sort.cpp: определяет точку входа для консольного приложения.
 #include "stdafx.h"#include <iostream>#include <iomanip>#include <ctime>using namespace std; 
void bubbleSort(int *, int); // прототип функции сортировки пузырьком int main(int argc, char* argv[])
{    srand(time(NULL));    setlocale(LC_ALL, "rus");    cout << "Введите размер массива: ";    
int size_array; // длинна массива    cin >> size_array;     int *sorted_array = new int [size_array]; 
// одномерный динамический массив   
 for (int counter = 0; counter < size_array; counter++)   
 {       
 sorted_array[counter] = rand() % 100; 
// заполняем массив случайными числами        
cout << setw(2) << sorted_array[counter] << "  "; 
// вывод массива на экран   
 }    
cout << "\n\n";    
 bubbleSort(sorted_array, size_array); 
// вызов функции сортировки пузырьком   
  for (int counter = 0; counter < size_array; counter++)  
  {        
cout << setw(2) << sorted_array[counter] << "  "; 
// печать отсортированного массива  
  }    cout << "\n";     
system("pause");    
return 0;} 
void bubbleSort(int* arrayPtr, int length_array) 
// сортировка пузырьком{ int temp = 0; 
// временная переменная для хранения элемента массива bool exit = false;
 // болевая переменная для выхода из цикла, если массив отсортирован  while (!exit) // пока массив не отсортирован {  exit = true;  for (int int_counter = 0; int_counter < (length_array - 1);
int_counter++) 
// внутренний цикл   
 //сортировка пузырьком по возрастанию - знак >  
  //сортировка пузырьком по убыванию - знак <    if (arrayPtr[int_counter] > arrayPtr[int_counter + 1])
 // сравниваем два соседних элемента  
  {     // выполняем перестановку элементов массива     temp = arrayPtr[int_counter];     
arrayPtr[int_counter] = arrayPtr[int_counter + 1];   
  arrayPtr[int_counter + 1] = temp;    
 exit = false; // на очередной итерации была произведена перестановка элементов    }
 }
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Nшкольников делят k яблок поровну, неделяющийся остаток остается в корзинке. сколько яблок достанется каждому школьнику? входные данные программа получает на вход числа n и k - целые, положительные, не превышают 10000. нужно записать на языке программирования питон(python)
Ваше имя (никнейм)*
Email*
Комментарий*