ShafetdinovAndrei
?>

Дан массив из n чисел. составить программу для вычисления суммы элементов массива, имеющих чётные индексы. паскаль

Информатика

Ответы

shturman-765255
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
  Write('Сумма элементов с четными индексами ',
      a.Where((x,i)->i.IsOdd).Sum)
end.

Пример
n= 13
81 6 -34 -33 -13 86 -14 -49 -28 -20 -93 5 -62
Сумма элементов с четными индексами -5
gsktae7
1. Изучала ли ты информатику в школе?
Да , мы изучали информатику в школе!
2. Как звали учителя по этому предмету?
Её звали Анна Григорьевна.
3. Какой был номер кабинета?
Номер кабинета иформатики - 21
4. Что больше всего запомнилось из уроков?
Разные опыты секреты и хитрости с компьютерами!
5. Что пригодилось в жизни из этих знаний?
Да сейчас у меня очень много техники, если бы я не изучал бы информатику в школе то я бы не мог пользоваться техникой.
6. Для каких целей ты используешь компьютер?
Програмирование.
lazarevaavrora
ЕСЛИ БУДЕТ НЕ ПРАВИЛЬНО НЕ БАНЬТЕ Я НЕ 8 класс

Задача
Требуется написать программу, вычисляющую значение какой-либо функции у = f(x). Допустим, такой:

у = x – 2, если x > 0,
y = 0, если x = 0,
y = |x|, если x < 0.
Решение
При определении значений подобных функций переменная y вычисляется по-разному (по разным формулам) в зависимости от значения x.

Такие задачи решаются с конструкции условного оператора if - else. Поскольку в данном случае мы имеем три условия (x > 0, x = 0 и x < 0), то потребуется использование еще вложенной конструкции if - else, т. к. в языке Pascal нет оператора множественного ветвления (оператор case в данном случае не подходит).

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дан массив из n чисел. составить программу для вычисления суммы элементов массива, имеющих чётные индексы. паскаль
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Timurr007
Анна егорович526
Yuliya
mzia-mzia-60682
testovvanya
Adassa00441
kormilitsynarita
andrey4work918
Dmitrii1763
lestnica
people33
nchalov2
Vs1377
znaberd786
marinarodina90