denis302007
?>

Напишите программу которая увеличивает введенные число с клавиатуры в 3 раза если оно отрицательное и уменьшает на 8 если оно положительное

Информатика

Ответы

Кириллов57
Program z123;
var  a: integer;
begin  read(a);  if a > 0 then    a := a - 8  else a := a * 3;  writeln(a);end.
Напишите программу которая увеличивает введенные число с клавиатуры в 3 раза если оно отрицательное
katarinacorvus825

Объяснение:

F1...F12 функциональные клавиши в верхнем ряду стандартной клавиатуры. Используются для запуска привязанных к ним стандартных функций. Действие клавиш зависит от активной в данный момент программы.  Как правило переименовать/редактировать, F3 - найти/замениить, F4 - работает по разному.

Красные подписи на ваших функциональных клавишах означают управление звуком и будут работать только при установке специального драйвера (программы, позволяющей компьютеру задействовать все функции устройства) этой конкретной клавиатуры. Задействованы они могут быть только при нажатой дополнительной кнопке с подписью типа "Fn" тоже красного цвета.

Galkin683
Дискеты формата 3,5" может иметь разную ёмкость
Но возьмём стандартную 1440 КБайт = 1 474 560 Байт
Так как на носителе надо отталкиваться не только от объёма но и от размера кластера, то получается -> на такой дискете имеется 2880 кластеров из которых доступно 2847, объём одного кластера 1474560/2880 = 512 Байт. Следует что в первых двух случаях а) и б) будет одинаковое кол-во файлов так как не превышает минимального объёма кластера, получаем 2847 файлов которое равняется кол-ву доступных кластеров на дискете. Вариант в) получаем 1030/512=2,01 т.е. больше двух кластеров. Для хранения одного файла размеров 1030 требуется 3 кластера -> 2847/3=949 файлов.

P.S. Думаю достаточно подробно описал.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу которая увеличивает введенные число с клавиатуры в 3 раза если оно отрицательное и уменьшает на 8 если оно положительное
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Евгений1286
mouse-0211fsb3509
evatautes
Mukhlaev-Olga
Жуков219
avdeevau807
anna241273
Kamil
Dmitrii1763
beglovatatiyana
Александр1991
abadaeva
Roman343247
gallows-warlike-0z
Yuliya mikhail
▲