laleonaretouch
?>

Напишите программу для вывода кодов букв из заданного диапазона на усмотрение пользователя, например от 'j' до 'w'.

Информатика

Ответы

Станиславович ыфвыв
 Вот на С++, код можете также здесь посмотреть https://ideone.com/e1a89S

#include <iostream>
using namespace std;

int main()
{
char a, b;
cin >> a >> b;
for(; a<= b; ++a) {
cout << (size_t)a << "-" << a << endl;
}
return 0;
}
gurman171
1)      Целая часть от деления:                Остаток от деления:
                 128 div 16 = 8                              128 mod 16 = 0
                   8 div 16 = 0                                   8 mod 16 = 8
                   0 div 16 = 0                                    0 mod 16 = 0
Остаток от деления записываем в обратном порядке. Получаем число в 16-ой системе счисления: 080
128 = 080^16
2)      Целая часть от деления                  Остаток от деления
             100 div 16 = 6                                100 mod 16 = 4
               6 div 16 = 0                                    6 mod 16 = 6
               0 div 16 = 0                                     0 mod 16 = 0
Остаток от деления записываем в обратном порядке. Получаем число в 16-ой системе счисления: 064
100 = 064^16
3) Для перевода дробной части числа последовательно умножаем дробную часть на основание 16. В результате каждый раз записываем целую часть произведения.
0.125*16 = 2 (целая часть 2)
0*16 = 0 (целая часть 0)
0*16 = 0 (целая часть 0)
0*16 = 0 (целая часть 0)
Получаем число в 16-ой системе счисления: 2000
0.125 = 2000^16
4) Целая часть от деления                  Остаток от деления
      345 div 16 = 21                                  345 mod 16 = 9
        21 div 16 = 1                                     21 mod 16 = 5
        1 div 16 = 0                                        1 mod 16 = 1
Остаток от деления записываем в обратном порядке. Получаем число в 16-ой системе счисления: 159
345 = 159^16
Для перевода дробной части числа последовательно умножаем дробную часть на основание 16. В результате каждый раз записываем целую часть произведения.
0.75*16 = 12 (целая часть 12)
0*16 = 0 (целая часть 0)
0*16 = 0 (целая часть 0)
0*16 = 0 (целая часть 0)
Получаем число в 16-ой системе счисления: C000
0.75 = C000^16
В итоге получаем число: 159.C000^16
rada8080
4)
var
    a, b: integer;

function max(a, b: integer): integer;
begin
    if a > b then max := a else max := b;
end;

begin
    readln(a, b);
    writeln(max(a, 2 * b) * max(2 * a - b, b));
end.

5)
const
    n = 10;

var
    a: array[1..n] of integer;
    i, s: integer;

begin
    for i := 1 to n do
    begin
        readln(a[i]);
        if i mod 2 = 0 then s := s + a[i];
    end;
    writeln(s);
end.

6)
const
    handsfree = false;

var
    a: array[1..100, 1..100] of real;
    product: real;
    i, j, m, n: integer;

begin
    {ввод матрицы}
    if handsfree then begin
        n := random(20) + 2;
        m := random(20) + 2;
    end
    else begin
        write('n, m =');
        readln(n, m);
    end;
    
    writeln('Данные матрицы:');
    for i := 1 to m do
    begin
        for j := 1 to n do
            if handsfree then begin
                a[i, j] := random(100) - 50;
                write(a[i, j]:4, ' ')
            end
            else
                read(a[i, j]);
        writeln;
    end;
    
    product := 1;
    for i := 1 to m do
        for j := 1 to n do
            if a[i, j] > 0 then
                product := product * a[i, j];
    writeln('product = ', product);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу для вывода кодов букв из заданного диапазона на усмотрение пользователя, например от 'j' до 'w'.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Аношкина1696
JisesLove19955
vlebedeva81
skorykin123371
tsigankova2018
Irina Svetlana
Fomin Korablev1781
tyrnaus
westgti77105
alexfold
Chutaeva381
iivanov54
saint158
gardenkafe
merx80
▲