skryabinamaria
?>

Программа на c++ напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. учтите, что числа могут быть отрицательными. входные данные входная строка содержит два целых числа. выходные данные программа должна вывести произведение введённых чисел. примеры входные данные 6 12 выходные данные 72 входные данные -7 15 выходные данные -105

Информатика

Ответы

elenakarpova709
#include <iostream>
using namespace std;  

int multiply(int x, int y)
{
    if(y == 0)
      return 0;
      if(y > 0)
      return (x + multiply(x, y - 1));
       if(y < 0)
      return -multiply(x, -y);
}
   
int main()
{
   int a, b;
   cin >> a >> b;
   cout << multiply(a, b) << endl;
   return 0;
}
char40
#include <cstdio>
#include <cstdlib>

int
main(void)
{
    int a = 0;
    int b = 0;
    scanf("%d %d", &a, &b);
    long long mul = 0;
    for (int i = 0; i < abs(a); i++) {
        mul += b;
    }
    if (a < 0) {
        mul = -mul;
    }
    printf("%lld\n", mul);
    return 0;
}
Коваленко

Для алфавита нужно выделить 5 бит на 1 символ

т.к.2^4=16 символов - мало

2^5=32

т.к. всего в пароле 15 символов то весить он будет

15*5=75 бит

1 пароль по условию кодируется минимально возможным целым количеством байт

75/8=9,375

т.е. для хранения пароля нужно 10 байт

Один пароль "весит" 10 байт.

У нас — 20 пользователей (и 20 паролей соответственно).

Следовательно, они "весят" 10х20 = 200 байт.

Для пользователей выделено дополнительно 10 байт, т.е. еще 200 байт на всех

т.е. для хранения сведений нужно 200+200 байт 400 байт

larinafashion829

1. Какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 4 раза? i:=3;

while i<=... do begin

writeln('Привет!');

i:=i+1;

end;

После каждого шага цикла к i прибавляется 1.

Изначально i = 3. Поэтому чтобы цикл выполнился ровно 4 раза, i сможет принять значения 3, 4, 5, 6.

Значит, нужно записать вместо ... число 6.

ответ: 6

2. Сколько раз будет выполнен этот цикл?

i:=6;

while i<5 do begin

writeln('Привет!');

i:=i+1;

end;

Т.к. i = 6, то на первом шаге цикла неравенство 6 < 5 будет уже неверно. Поэтому данный цикл выполнится 0 раз.

ответ: 0

3. Какое число будет выведено на экран в результате выполнения этого цикла?

i:=1;

write('9');

while i<3 do begin

write(i);

i:=i+1;

end;

Сначала до цикла будет выведено число 9.

Затем начинается цикл:

1 шаг (i = 1) : выведется 1

2 шаг (i = 2) : выведется 2

На 3 шаге (i = 3) цикл завершится, т.к. неравенство 3 < 3 неверно.

ответ: 912

4. Какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 2 раза?

i:=4;

while i>=... do begin

writeln('Привет!');

i:=i-1;

end;

После каждого шага цикла от i отнимается 1. Изначально i = 4. Поэтому чтобы цикл выполнился ровно 2 раза, i сможет принять значения 4, 3.

Значит, нужно записать вместо ... число 3.

ответ: 3

5. Какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 2 раза?

i:=...;

while i>=6 do begin

writeln('Привет!');

i:=i-1;

end;

После каждого шага цикла от i отнимается 1. Цикл завершается при i = 5. Поэтому чтобы цикл выполнился ровно 2 раза, i сможет принять значения 7, 6.

Значит, нужно записать вместо ... число 7.

ответ: 7

6. Какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 3 раза?

i:=...;

while i<=7 do begin

writeln('Привет!');

i:=i+1;

end;

После каждого шага цикла к i прибавляется 1. Цикл завершается при i = 8. Поэтому чтобы цикл выполнился ровно 3 раза, i сможет принять значения 5, 6, 7.

Значит, нужно записать вместо ... число 5.

ответ: 5

7. Чему будет равно значение переменной «a» после выполнения этого цикла?

i:=2;

a:=12;

while i<5 do begin

a:=a+i;

i:=i+1;

end;

1 шаг цикла (i = 2) : a = a + i = 12 + 2 = 14

2 шаг цикла (i = 3) : a = a + i = 14 + 3 = 17

3 шаг цикла (i = 4) : a = a + i = 17 + 4 = 21

На 4 шаге (i = 5) цикл завершится, т.к. неравенство 5 < 5 неверно.

ответ: 21

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Программа на c++ напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. учтите, что числа могут быть отрицательными. входные данные входная строка содержит два целых числа. выходные данные программа должна вывести произведение введённых чисел. примеры входные данные 6 12 выходные данные 72 входные данные -7 15 выходные данные -105
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

yurazharov
Мария
Boris1247
Valentinovna
red-sun2
Annabill1987
GALINAMTO
Lapushkin1988
melnik-738
klimovala2
Nzharenikova
Vrezh
turoverova5
Dmitrii sergei463
lobanosky162