Yevgenevich
?>

Написать программу на питоне.: дано действительное число х и натурально число n.посчитать sinx*(sinx)^2**(sinx)^n

Информатика

Ответы

rabchek145200614
Import math
x= float(input())
n = int(input())
result = 1
for i in range(n):
     result *= math.sin(x)**i
print(result)
Федоровна-Васильева

1.V=24*2=48 байт = 384 бита

2.192 символа на стр- 30720 символов. Мощность алфавита 256 - значит в алфававите 256 знаков. 2 в степени восемь - равно 256.весь алфавит можно закодировать одним байтом (в одном байте - как раз восемь бит, степень двойки. Бит - принимает ДВА значения - 0 и 1 - отсюда основание 2, которое возводим в восемь :) ) на каждый символ текста надо потратить один байт памяти. Итого получаем 30720 БАЙТ. в одном КИЛОБАЙТЕ 1024 байта. Делим 30720 на 1024 получаем 30 КБайт.

3.в 2 раза уменьшился

4

1024000/8=128000 (перевели в байты) 

128000/1024=125кбайт/сек (перевели в килобайты) 

125*5= 625 килобайт

5.

всего используется 12 букв + 10 цифр = 22 символа 

для кодирования 22 вариантов необходимо использовать 5 бит, так как , т.е. 4 бит не хватит (они позволяют кодировать только 16 вариантов), а 5 уже достаточно 

таким образом, на каждый символ нужно 5 бит (минимально возможное количество бит) 

полный номер содержит 6 символов, каждый по 5 бит, 30 бит один номер. 

по условию каждый номер кодируется целым числом байт (в каждом байте – 8 бит), поэтому требуется 5 байт на номер ( ), 4 байтов не хватает, а 5 – минимально возможное количество 

на 32 номеров нужно выделить 160 байтов приблизительно 192байта 

правильный ответ – 160байт...т.к 32*5=160 или приблизетельно 192байта.

Объяснение:

DzukaevAlekseevich

ответ:var err, right, answer : integer;

BEGIN

err := 0; right := 0;

writeLn('Сейчас Вам будет предложен тест по архитектуре. ');

writeLn('К каждому вопросу три варианта ответа. ');

writeLn('Вы должны ввести номер правильного ответа и нажать <Еnter>');

writeLn;

writeLn('Архитектор Исаакиевского собора: ');

writeLn('1. Доменико Трезини');

writeLn('2. Огюст Монферран');

writeLn('3. Карл Росси');

Write('Ваш ответ: ');ReadLn(answer);

if answer = 2 then begin

WriteLn('Правильно');

right := right +1;

end

else begin

WriteLn('Неправильно');

err := err + 1;

end;

writeLn;

writeLn('Архитектор Зимнего дворца: ');

writeLn('1. Франческо Бартоломео');

writeLn('2. Карл Росси');

writeLn('3. Огюст Монферран');

Write('Ваш ответ: ');ReadLn(answer);

if answer = 2 then begin

WriteLn('Правильно');

right := right +1;

end

else begin

WriteLn('Неправильно');

err := err + 1;

end;

writeLn;

writeLn('Невский проспект получил свое название: ');

writeLn('1. По имени реки, на которой стоит Санк-Петербург');

writeLn('2. По имени близко расположенной Александро-Невской лавры');

writeLn('3. В память о знаменитом полководце - Александре Невском');

Write('Ваш ответ: ');ReadLn(answer);

if answer = 2 then begin

WriteLn('Правильно');

right := right +1;

end

else begin

WriteLn('Неправильно');

err := err + 1;

end;

WriteLn('Правильных ответов: ', right);

WriteLn('Неправильных ответов: ', err);

END.

Объяснение:

P.S. Это конечно не то,но думаю по аналогию сможешь составить

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на питоне.: дано действительное число х и натурально число n.посчитать sinx*(sinx)^2**(sinx)^n
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Ohokio198336
Reginahappy
Кирилл-Анна1023
vladimir686
mila010982
ВитальевичЕвгеньевич346
Maksim Lokhov
VladimirovichKazakova1202
Как рандомизировать NDCDEVICEID?​
platonm777639
Designer
Кулагина_Владимир1179
juliavovo
elenaperemena8
goodsled
ВасильевнаСергей