Кристина910
?>

Составить программу которая заполняет массив а случайными целыми числами в диапазоне от 1 до 10 и вычисляет сумму элементов массива с индексом от n до m включительно. числа n и m введите с клавиатуры

Информатика

Ответы

uksusoval617
// PascalABC.NET 3.3, сборка 1549 от 17.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(10,1,10); a.Println;
  var (n,m):=ReadInteger2('Введите n и m:');
  Writeln('S=',a[n-1:m].Sum)
end.

Пример
1 8 9 1 2 1 10 4 10 2
Введите n и m: 3 6
S=13
D-posilochka
1.1 Кодирование растрового изображенияРастровое изображение представляет собой совокупность точек, используемых для его отображения на экране монитора. Объем растрового изображения определяется как произведение количества точек и информационного объема одной точки, который зависит от количества возможных цветов. Для черно-белого изображения информационный объем одной точки равен 1 биту, так как точка может быть либо черной, либо белой, что можно закодировать двумя цифрами — 0 или 1. Для кодирования 8 цветов необходимо 3 бита; для 16 цветов — 4 бита; для 64 цветов — 8 битов (1 байт) и т.д.
magsh99

/*Код соответствует тексту задания из файла. Последовательность вводится в строку через знаки пробела, нажатие клавиши Enter заканчивает ввод последовательности. Программа НЕ проверяет корректность введенных данных*/

#include <iostream>

bool is_prime(const int n);

int main(int argc, char* argv[])

{

   int numb, n_of_pr_numb = 0;

   long int sum = 0;

   do

    {

       std::cin >> numb;

       if(is_prime(numb))

       {

           sum += numb;

           n_of_pr_numb++;

       }

   } while (std::cin.peek() != '\n');

   std::cout << "The arithmetic mean: " << (n_of_pr_numb == 0 ? 0 : sum * 1. / n_of_pr_numb);

}

bool is_prime(const int n)

{

   if (n <= 1)

   {

       return false;

   }

   for (int i = 2; i <= pow(n, 1/2); i++)

   {

       if (n % i == 0)

       {

           return false;  

       }

   }

   return true;

}

Основные ошибки/недочеты Вашей реализации:

В функции pr строка for ( a = 2 ; a<=n ; a++) неверна, т.к. на последнем шаге число всегда будут сравнивать с самим собой, правильно for ( a = 2 ; a<n ; a++). Ну и нет смысла проверять до a=n-1, достаточно проверить до √n(об этом есть целая теорема).По условию никакого вывода слов "Простое/Не простое" не требуетсяСтрока cout << "n = "; лишняя, т.к. даже если на ввод будет подано несколько чисел, на экран "n = " будет выведено лишь в начале. Лучше уточнить для пользователя формат ввода.Смысл функции arif неясен, она выводит на консоль какие-то непонятные пользователю данные, затем возвращает s/i[ВНИМАНИЕ! Так как s и i целочисленные, то s/i не является средним арифметическим, это будет лишь целая часть от него. Правильнее s * 1./i или static_cast<double>(s)/i], а затем выводит это значение. Зачем разрывать cout на две функции - неясноВвод данных не должен находиться в функции проверки числа на простоту(да и смысл разбиения программы на функции пропадает)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу которая заполняет массив а случайными целыми числами в диапазоне от 1 до 10 и вычисляет сумму элементов массива с индексом от n до m включительно. числа n и m введите с клавиатуры
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Елена Ирина
ksv89
Дружинин
Dr-motoshop
cosmetic89
sales
Константин Андрей
Аврамец1911
zurabghiendzhoian886
juli19657
sbn07373
okunevo2010
a580028r
filimon131262
Asira926
▲