Daniil1945
?>

Напишите программу, которая бы определяла среднее арифметическое значение элементов массива (конечно, это будет вещественная величина типа real)

Информатика

Ответы

nadezhda81
// PascalABC.NET 3.3, сборка 1555 от 21.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
  Writeln('Среднее значение равно ',a.Average);
end.

Пример
n= 15
-50 -39 -10 49 35 -11 -34 34 -28 37 45 45 -24 42 2
Среднее значение равно 6.2
cometa94558
Большой, просторный, светлый дом.Ребят хороших много в нём.Красиво пишут и читают.Рисуют дети и считают.
В этот день гурьбой весёлойДружно мы шагаем в школу.
Каждый год школа дверь открывает.С теплотой всех детей принимает.Малыши - новосёлы вселяются.Знаешь ты, как они называются?
Ученикам велит садиться.Затем вставать и расходиться.В школе многим он велит,Ведь звонит, звонит, звонит.
Загадка про школу,про тот самый срок,Который ребятам Прозвонит звонок.

Стал теперь умней наш класс!Мы крючки и зонтикиСтали рисовать.Ты попробуй отгадать,Что же это за тетрадь? (Пропись)* * *Все рисунки вмиг сотрет,Если в ход она пойдет. (Стирательная резинка)* * *Пляшут Ира и Кирилл,Пляшут Таня, Даниил.Это просто танцы века! —В нашем классе... (дискотека)* * *В этом заведенииВсе перебывали.Двоечники, генииОтметки получали.Учились здесь артисты,Певцы, артиллеристы.Сюда хожу и я,И вы, мои друзья. (Школа)* * *Таблицу умноженияУчил я две недели.Скажу я без сомнения —Важнее нету дела!Ее запомнил на года!Хоть сколько будет лет,Я на любой пример всегдаДам правильный... (ответ)* * *Мы идем в медкабинет.Все боятся, а я — нет.Лица у ребят, как сливки, —Побледнели от... (прививки)* * *Для младших классов лишь одноОно — начальное... (звено)* * *Я болею, дома я,В школе все мои друзья.Дома быть мне непривычно,Врач мне выдал лист... (больничный)* * *Мы по улице ходилиИ о времени забыли.Дождь пошел. Стучит он гулко,Сорвана была... (прогулка)* * *Плох тот, ребята, ученик,Кто не ведет совсем дневникИ на уроках не бывает,А вместо школы в мяч играет.Скажите, как того назвать,Кто школу любит прогулять? (Прогульщик)* * *Все листочки скреплены,Не рассыплются они.Держит крепко, как прищепка,Металлическая... (скрепка)* * *Первая книга, что знанья дает,Ее первоклассник в портфеле несет.Всегда и повсюду, сегодня и встарьШкольнику очень нужен... (букварь)* * *
sashab82
Программа выглядит примерно так

program n_1;  type    nazw = array[0..9] of String[15];  const    ed : nazw = ('ноль','один','два','три','четыре','пять','шесть','семь','восемь','девять');    des: nazw = ('','десять','двадцать','тридцать','сорок','пятьдесят',                       'шестьдесят','семьдесят','восемьдесят','девяносто');    sot: nazw = ('','сто','двести','тристо','четыресто','пятьсот','шестьсот','семьсот','восемьсот','девятьсот');    dd : nazw = ('','одинадцать','двенадцать','тринадцать','четырнадцать','пятнадцать',                       'шестнадцать','семнадцать','восемьнадцать','девятнадцать');  var    s,d,e,x : Integer;    st      : String;  Begin    Write('Введите число [0..1000] :'); Readln(x);   if x=1000 then st:='тысяча' else begin    s:= x div 100; x:=x mod 100; st:=sot[s];    d:= x div 10; e:=x mod 10;    if (d=1) and (e<>0) then st:=st+dd[e]                        else st:=st+des[d]+ed[e];   end;    writeln(st);     End.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая бы определяла среднее арифметическое значение элементов массива (конечно, это будет вещественная величина типа real)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

innaterenina
Александра_Наталья1417
Екатерина655
marinazubcko16729
dashanna04225
eshabunina
aobuhta4
zelreiki
Нескажу25
pifpaf85
info126
deputy810
yana2211
sokolowskayaa
silviya
▲