alexander4590
?>

Напишите программу, решающую следующую . с клавиатуры вводятся количество пятерок, количество четверок и количество троек, полученных учащимся в четверти. на экран необходимо вывести проценты пятерок, четверок и троек от общего количества оценок, полученных учащимся в четверти. очевидно, что сумма процентов пятерок, четверок и троек должна быть равна 100 процентам. при выводе процентов используйте форматированный вывод, задав ширину выводимого результата 6, а количество знаков после десятичной точки — 1.

Информатика

Ответы

maslprod
var k5,k4,k3,s:integer;
begin
readln(k5,k4,k3);
s:=k5+k4+k3;
writeln('Пятёрок - ',k5/s*100:6:1,' %');
writeln('Четвёрок - ',k4/s*100:6:1,' %');
writeln('Троек - ',k3/s*100:6:1,' %');
end.

Пример:
5 3 2
Пятёрок - 50.0 %
Четвёрок - 30.0 %
Троек - 20.0 %
Voshchula David393
Const 
n=5;

Var
 ar:array[1..n] of integer;
 ar2:array[1..n] of integer;
 i,k:integer;

 function prost(a:integer):boolean;
 var i:integer;
 b:boolean;
  begin
  b:=true;
   for i:=2 to a div 2 do
    if a mod i=0 then
     begin;
      b:=false;
      break;
     end;
   if a=1 then b:=false;
  prost:=b;
 end;

  begin;
 randomize;
 k:=0;
  for i:=1 to n do
   begin;
    ar[i]:=random(101);
    write(ar[i]:4);
   end;
  writeln;
  for i:=1 to n do
  if prost(ar[i]) then
   begin;
    inc(k);
    ar2[k]:=ar[i];
    write(ar2[k]:4);
   end;
end.
kate281078
Компьютерная графика - одна из областей применения компьютеров. Создания рисунков на компьютере происходит с специально предназначенных программ - графических редакторов. 

Графический редактор - прикладное среду, предназначенное для создания и редактирования графических изображений.

Документом графического редактора является рисунок. По принципам построения графические изображения бывают растровые, векторные, фрактальные. 
Есть редакторы, которые поддерживают как векторную, так и растровую графику, благодаря встроенным программам для конвертации файлов из одного формата в другой. 
Растровое изображение состоит из маленьких одноцветных точек - пикселей (от англ. Picture element - элемент картинки). Это наименьший элемент растрового изображения, который характеризуется цветом и яркостью. 
Растр - представление изображения в виде двумерного массива точек, упорядоченных в строки и столбцы. 
Растровое изображение на экране состоит из равных по величине пикселей, которые при увеличении выглядят как квадратики. Для определения размера растрового рисунка указывают количество пикселей по вертикали и горизонтали, например. 
Растровые графические редакторы - Paint, Adobe Photoshop. 
Форматы хранения растровых изображений Bmp, Pcx, Tiff (для хранения отсканированных изображений), Psd, Jpeg, Gif, Fpx.

Векторное изображение состоит из готовых элементов (графических примитивов): отрезков прямых, эллиптических дуг, фрагментов прямоугольников, кругов и т.п.. Пользователь создает один из объектов, изменяет его параметры (размер, положение, угол поворота), а компьютер чертит его уже с измененными характеристиками. Процесс редактирования в векторных графических редакторах заключается в изменении параметров графических примитивов или добавлении новых объектов. 
Векторные графические редакторы - CorelDraw.

Форматы хранения векторных изображений Eps, Dcs, Pdf, Cdr, Cdx, Cmx, Cpx. 
Фрактальная изображение, как и векторное, основанное на математических вычислениях. Однако базовым элементом фрактальной графики является сама математическая формула, то есть никаких объектов в памяти компьютера не хранится и изображение формируется исключительно по уравнениям. Таким образом строят как простейшие регулярные структуры, имитирующих природный ландшафт, так и трехмерные объекты. 
Отдельным предметом считается трехмерная (3D) графика, изучающая приемы и методы построения объемных моделей объектов в виртуальном пространстве. Как правило, в ней сочетаются векторный и растровый формирования изображений.

Трехмерная графика нашла широкое применение в таких отраслях, как научные расчеты, инженерное проектирование, компьютерное моделирование объектов!

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, решающую следующую . с клавиатуры вводятся количество пятерок, количество четверок и количество троек, полученных учащимся в четверти. на экран необходимо вывести проценты пятерок, четверок и троек от общего количества оценок, полученных учащимся в четверти. очевидно, что сумма процентов пятерок, четверок и троек должна быть равна 100 процентам. при выводе процентов используйте форматированный вывод, задав ширину выводимого результата 6, а количество знаков после десятичной точки — 1.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

reception
alekseymedvedev1981
dmtr77
mv7095
natalia-shelkovich
Dmitrychekov9
makitra08
andrew55588201824
svetrusval
Nataliya Aleksandr1197
Никита227
Less2014
denis302007
Gaziev1636
Devaunka40
▲