anton
?>

2. даны катеты прямоугольного треугольника . найти его гипотенузу и периметр напишите программу паскаль

Информатика

Ответы

znaberd786
// PascalABC.NET
// Даны катеты прямоугольного треугольника.
// Найти его гипотенузу и периметр.

var
    a, b : real;
    
begin
    write('Введите длину катета а: ');
    readln(a);
    write('Введите длину катета b: ');
    readln(b);
    var c := sqrt( sqr(a) + sqr(b) );
    var p := a + b + c;
    writeln('Длина гипотенузы равна ', c);
    writeln('Периметр треугольника равен ', p)
end.

2. даны катеты прямоугольного треугольника . найти его гипотенузу и периметр напишите программу паск
kuhonka2021
// PascalABC.NET 3.2, сборка 1374 от 10.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('*** Матрица А ***');
  var a:=MatrRandom(4,7,-50,50); a.Println(4);
  Writeln('*** Матрица B ***');
  var b:=MatrRandom(4,7,-50,50); b.Println(4);
  Writeln(4*a.ColCount*'-');
  Writeln('*** Матрица А-B ***');
  for var i:=0 to 3 do begin
    for var j:=0 to 6 do Write(a[i,j]-b[i,j]:4);
    Writeln
    end;
end.

Пример
*** Матрица А ***
  11 -12 -37  22   3  -8  16
  -2  21  31   4  -1  13  20
  18 -42 -46 -17  19   8 -14
 -26 -32  -2  31 -26 -43 -31
*** Матрица B ***
  13 -14  12 -37   2 -12  34
  26  25 -47   2 -42   1 -43
  44  -6  -1  24  37  -9  -3
 -30   3 -29 -39 -11  -8 -14

*** Матрица А-B ***
  -2   2 -49  59   1   4 -18
 -28  -4  78   2  41  12  63
 -26 -36 -45 -41 -18  17 -11
   4 -35  27  70 -15 -35 -17
karasev17764
Pascalabc.net var   a: array[1..10000] of integer;   kz,maxp,n,i,j: integer;   begin     i: =0;   maxp: =integer.minvalue;   writeln ('готов к приему чисел');   repeat     i: =i+1;     readln (a[i]);     until a[i]=0;   n: =i-1;   readln (kz);   for i: =1 to n-1 do      for j: =2 to n do        if maxp< (a[i]*a[j]) then maxp: =(a[i]*a[j]);     writeln ('получено ',n,' чисел');   writeln;   writeln ('полученное контрольное значение: ',kz);   writeln;   writeln ('вычисленное контрольное значение: ',maxp);   writeln;   if kz=maxp      then writeln ('контроль пройден')     else writeln ('контроль не пройден'); end. результаты: 1) готов к приему чисел 1 2 3 4 5 0 20 получено 5 чисел полученное контрольное значение: 20 вычисленное контрольное значение: 20 контроль пройден 2) готов к приему чисел 1 2 3 4 5 6 0 20 получено 6 чисел полученное контрольное значение: 20 вычисленное контрольное значение: 30 контроль не пройден

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

2. даны катеты прямоугольного треугольника . найти его гипотенузу и периметр напишите программу паскаль
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vgolentsova
beliaeva2
TSKaraulova
Ерохин
olyaartemenko
kodim4
ПодлеснаяМакарова1883
Ячейка&nbsp;Excel&nbsp;не&nbsp;может содержать​
Kuzina Sergeevna
optima3559
guzelda19904850
seletan1
janetp
infosmolenskay
whitecatrussia5398
irnik65