tarkhanovilya
?>

Работа на си шарп.желательно с пояснениями хода работы . составить программу для нахождения объема прямой призмы, в основании которой лежит равносторонний треугольник со стороной а. высота призмы h

Информатика

Ответы

vera141187
Вот программа на C#.
Объяснил как можно подробней.
Работа на си шарп.желательно с пояснениями хода работы . составить программу для нахождения объема п
ОвчинниковаТатьяна
Язык программирования Pascal ABC
var n,k,i,j,d,c:integer;
label 1,2;
begin
1:writeln('Количество месяцев в календаре планеты Мульти:');
readln(n);
if (n>109)or(n<1) then
begin
writeln('Ошибка! Количество месяцев должно быть меньше или равно 109. Повторите ввод.');
goto 1;
end;
2:writeln('Номер дня на который приходится первое число первого месяца нового года:');
readln(k);
if (k>7)or(k<1) then
begin
writeln('Ошибка! Номер дня должен быть в диапозоне от 1 до 7. Повторите ввод.');
goto 2;
end;
d:=k;
for i:=1 to n do
begin
for j:=1+(k-1) to 30 do
begin
if (d=5)and(j=13) then c:=c+1;
d:=d+1;
if d>7 then d:=1;
end;
k:=1;
end;
writeln('Количество несчастливых дней в этом году: ',c);
end.
Mariya-Karaseva
Язык программирования Pascal ABC
var n,k,i,j,d,c:integer;
label 1,2;
begin
1:writeln('Количество месяцев в календаре планеты Мульти:');
readln(n);
if (n>109)or(n<1) then
begin
writeln('Ошибка! Количество месяцев должно быть меньше или равно 109. Повторите ввод.');
goto 1;
end;
2:writeln('Номер дня на который приходится первое число первого месяца нового года:');
readln(k);
if (k>7)or(k<1) then
begin
writeln('Ошибка! Номер дня должен быть в диапозоне от 1 до 7. Повторите ввод.');
goto 2;
end;
d:=k;
for i:=1 to n do
begin
for j:=1+(k-1) to 30 do
begin
if (d=5)and(j=13) then c:=c+1;
d:=d+1;
if d>7 then d:=1;
end;
k:=1;
end;
writeln('Количество несчастливых дней в этом году: ',c);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Работа на си шарп.желательно с пояснениями хода работы . составить программу для нахождения объема прямой призмы, в основании которой лежит равносторонний треугольник со стороной а. высота призмы h
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

zagadka27
vlebedeva81
artemiusst
Mexx9050
nordwokintos4
Janaz842060
kizyaev6651
kav511
Динков
smook0695
koptevan6
nuralievelsh
Андрей_Станиславовна
Gradus469
Liliya1106