VladimirovnaViktorovich
?>

Написать программу, которая вычисляет и печатает объемы цилиндров высотой h=20 и радиусами оснований от 1 до 15. написать программу нужно в паскале

Информатика

Ответы

morozmd
var
  h, i: byte;
  z: real;
begin
  h := 20;
  for i := 1 to 15 do
    writeln('Объем цилиндра с основанием ', i, ' = ', (pi * (i * i) * h):2:2);
end.

Написать программу, которая вычисляет и печатает объемы цилиндров высотой h=20 и радиусами оснований
Silaev988
Program question;

var
   a: string;
   b: integer;

begin
     writeln('Сколько тебе лет?:');
     readln(b);
     if b > 17 then begin
                                 writeln('В каком институте ты учишься?:');
                                 readln(a);
                                 writeln(a, ' хороший институт');
                                 writeln('До следующей встречи!');
                            end
          else
     if b <= 17 then begin
                                 writeln('В какой школе ты учишься?');
                                 readln(a);
                                 writeln(a, ' не плохая школа');
                                 writeln('До следующей встречи!');
                                 end;
end.
hrviko
Тексты вводятся в память компьютера с клавиатуры. На клавишах написаны привычные нам буквы, цифры, знаки препинания и другие символы. В оперативную память они попадают в двоичном коде. Это значит, что каждый символ представляется 8-разрядным двоичным кодом.

Кодирование заключается в том, что каждому символу ставится в соответствие уникальный десятичный код от 0 до 255 или соответствующий ему двоичный код от 00000000 до 11111111. Таким образом, человек различает символы по их начертанию, а компьютер - по их коду.

Удобство побайтового кодирования символов очевидно, поскольку байт - наименьшая адресуемая часть памяти и, следовательно, процессор может обратиться к каждому символу отдельно, выполняя обработку текста. С другой стороны, 256 символов – это вполне достаточное количество для представления самой разнообразной символьной информации.

Теперь возникает вопрос, какой именно восьмиразрядный двоичный код поставить в соответствие каждому символу.

Понятно, что это дело условное, можно придумать множество кодировки.

Все символы компьютерного алфавита пронумерованы от 0 до 255. Каждому номеру соответствует восьмиразрядный двоичный код от 00000000 до 11111111. Этот код просто порядковый номер символа в двоичной системе счисления.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая вычисляет и печатает объемы цилиндров высотой h=20 и радиусами оснований от 1 до 15. написать программу нужно в паскале
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

beliaevabeliaeva-olesya35
Vladimirovna1858
Герасимова107
tanya62soldatova72
РобертИрина
os2854
Александр734
irinatikhonov
Aleksandr
ekasatkina
zabava-83
nikolai37
Ямпольский
Salko17
iracaenko153