Alekseevna1811
?>

Паскаль Написать программу, которая проверяет, образуют ли элементы массива Х[1..10], введенного с клавиатуры неубывающую последовательность. Только без использования

Информатика

Ответы

tanyaandreeva728
#include <iostream>
#include <random>
#include <ctime>
using namespace std;

mt19937 gen(time(0));
uniform_int_distribution<> uid(0, 19);
void replace(int *a, int n, int k)
{
int last = a[n];
for (int i = n - 1; i >= k; i--) {
a[i + 1] = a[i];
}
a[k] = last;
}

int main()
{
int n = 0, k = 0;
cin >> n;
int *a = new int[n];
if (n <= 100) {
 for (int i = 0; i <= n; i++) {
  a[i] = uid(gen); cout << a[i] << " ";
 }
 cout << endl; cin >> k;
 if (k <= n) {
  replace(a, n, k - 1);
  for (int i = 0; i <= n; i++) {
   cout << a[i] << " "; }
 } else {
  cout << "Error" << endl;
 }
} else {
 cout << "Error!" << endl;
}
delete[] a;
return 0;
}
Gaziev1636
Дискретные сигналы (они же цифровые) - принимают конечное число значений функции:
примеры дискр:
- энергетические уровни атома,
- сигналы светофора
- символы, слова... и т. д. и т. п.
непрерывный (он же аналоговый) - принимает бесконечное количество значений функции, амлитуда и время которого меняются непрерывно.
примеры непрерывных:
- звуковая волна,
- диаграмма изменения влажности, напряжения, и других некоторых физических величин

для преобразования непрерывного сигнала в дискретные производят дискретизацию. Процесс дискретизации сопровождается потерей информации если частота дискретизации в 2 раза меньше максимальной частоты непрерывного сигнала по теореме Найквиста... В России эту теорему называют Котельникова

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль Написать программу, которая проверяет, образуют ли элементы массива Х[1..10], введенного с клавиатуры неубывающую последовательность. Только без использования
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bistrayakuhnya46
aobuhta4
foto5113161
stasletter
aedunova3
AndreiAstakhva1442
Rizhov Alekyan325
mkovanov
Natacha3636672
vikabobkova2010
inris088
laktionova-natal
cometa94558
rechkai64
retropluse832