Написать программу на языке Pascal Дано реальное число X.найти среднюю геометрическую последней цифры и первой цифры дробной части всего заданного реального числа
Var a: array of integer; var i: byte; var b: boolean; begin b: =true; setlength(a,8); var n: =0; writeln('введите число: '); readln(i); var d: =i; while i< > 0 do begin a[n]: =i mod 2; i: =i div 2; inc(n); end; setlength(a,n); for i: =0 to n-1 do begin if n=0 then begin write(0); break; end; swap(a[i],a[n-1]); write(a[i]); end; for i: =1 to n-1 do begin if n=0 then break; if a[i-1]< > a[i] then begin b: =false; break; end; end; if (b=false) then write(' = ',d,' это не палиндром') else write(' = ',d,' это палиндром'); end.
denisov4
07.06.2020
#include <iostream> #include <cmath> using namespace std; double eps = 0.000001; double sq(double a, double b, double c) { double p = (a + b + c) / 2; return sqrt(p * (p - a) * (p - b) * (p - c)); } int main() { double a1, b1, c1, a2, b2, c2; cin >> a1 >> b1 >> c1 >> a2 >> b2 >> c2; if (sq(a1, b1, c1) >= sq(a2, b2, c2) - eps && sq(a1, b1, c1) <= sq(a2, b2, c2) + eps) cout << "YES"; else cout << "NO"; }
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу на языке Pascal Дано реальное число X.найти среднюю геометрическую последней цифры и первой цифры дробной части всего заданного реального числа