Var i,s,n,m:integer; begin Write('Количество чисел равно '); Readln(n); s:=0; Writeln('Введите все числа'); for i:=1 to n do begin Read(m); if (abs(m mod 10)=5) and (m mod 3=0) then s:=s+m end; Writeln('s=',s) end.
Gaziev1636
18.01.2022
1) Program n1; const n=5; var a: array [1..n] of integer; i: integer; begin for i:=1 to n do readln(a[i]); for i:=1 to n do if( i mod 2=0) then a[i]:=0 else a[i]:=1; for i:=1 to n do writeln(a[i]); end. 2) Program n2; const n=25; var a: array [1..n] of integer; i,k: integer; begin randomize; for i:=1 to n do begin a[i]:=random(5)+1; if a[i]<3 then k:=k+1; end; writeln(k); end. 3) Program n3; const n=5; var a: array [1..n] of integer; i,S: integer; begin S:=0; for i:=1 to n do readln(a[i]); for i:=1 to n do if (a[i]<0) then S:=S+a[i]; writeln(S); end.
Lianchikavon
18.01.2022
1 DIM A(10, 5) RANDOMIZE TIMER FOR I = 1 TO 10 FOR J = 1 TO 5 A(I, J) = INT(RND * 10) PRINT A(I, J); S = S + A(I, J) ^ 2 NEXT J PRINT , S NEXT I
Исправленный вариант (предыдущий находил только суммы квадратов элементов). Уменьшил размерность массива и значение элементов, что бы через-чур большие числа не появлялись DIM A(3, 3) RANDOMIZE TIMER P = 1 FOR I = 1 TO 3 FOR J = 1 TO 3 A(I, J) = INT(RND * 5) PRINT A(I, J); S = S + A(I, J) ^ 2 NEXT J P = P * S PRINT NEXT I PRINT PRINT "P="; P
2 DIM A(10) RANDOMIZE TIMER P = 1 FOR I = 1 TO 10 A(I) = INT(RND * 20) - 10 PRINT A(I); " "; IF A(I) > O THEN S = S + A(I) P = P * A(I) N = N + 1 END IF NEXT I PRINT PRINT "S="; SPRINT "P="; PPRINT "Kol-vo="; N
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу паскаль 40 найти сумму нечётных чисел кратных 3 которые заканчиваются цифрой 5.
i,s,n,m:integer;
begin
Write('Количество чисел равно ');
Readln(n);
s:=0;
Writeln('Введите все числа');
for i:=1 to n do
begin
Read(m);
if (abs(m mod 10)=5) and (m mod 3=0) then s:=s+m
end;
Writeln('s=',s)
end.