mileva84
?>

составить программу. "Дано число (вводится пользователем с клавиатуры Если число делится на 3 или оканчивается на 7, то вывести сообщение: Число удовлетворяет условию. В противном случае вывести сообщение: Заданное число не соответствует условию." язык - Паскаль

Информатика

Ответы

Alyona1692

ДЗ для ВЕРЫ ВИКТОРОВНЫ:

Объяснение:

Var I, N, m: integer;

{Выводит таблицу квадратов до N числа}

Begin

Readln(N); //Что вводим в этой строке и зачем? Как можно подсказать пользователю, что ввести?  

{Вводим до какого числа нам нужно получить квадрат; Подсказать можно через WRITELN}

Writeln('Таблица квадратов чисел от 1 до N'); //Сколько раз выполняется этот оператор?

{Один раз}

For i:=1 to N do //Сколько раз выполнится цикл?

{N раз}

Begin //Зачем снова писать операторные скобки?

{Затем, что это цикл, который всегда обособляется и отделяет от остальных операторов}

m:=i*I;

Writeln(I,' ',m); //Как по-другому оставить пробелы между столбиками?

{Можно сделать так    -     Writeln(I:3,m:16);}

End;

End.

Verdievruslan

Работает на 1000 элементов,нужно узнать диапазон N,элементы я так понял создаются рандомные,если вводятся с клавиатуры то просто убираем randomize и пишем вместо присваивания (mas[i]:=random(19)-10; )пишем read(который в коментах)

label l;

var

 mas:array[1..1000] of longint;

 n,i:longint;

begin

 readln(n);

 randomize;

 for i:=1 to n do

 begin  

   mas[i]:=random(19)-10;

  //read(mas[i]);

   write(mas[i],' ');

 end;

 for i:=n-4 to n do

 begin

   if mas[i] > 0 then

   begin  

     mas[i]:=mas[i]-2*mas[i];

     goto l;

   end;

   if mas[i] < 0 then

     mas[i]:=abs(mas[i]);

   l:

 end;

 writeln;

 for i:=1 to n do

   write(mas[i],' ');

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

составить программу. "Дано число (вводится пользователем с клавиатуры Если число делится на 3 или оканчивается на 7, то вывести сообщение: Число удовлетворяет условию. В противном случае вывести сообщение: Заданное число не соответствует условию." язык - Паскаль
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

annakuznetsova841
svetarakityanskaya
tcmir
verkop9
gusrva3001
Voronin-Albertovich
Lolira64
antoska391
ПетровичЖивотовская1245
Natalya1895
Сурат1199
marinakmaa86
Григорьевич915
kisuhakisa
tatry2005