// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018
// Внимание! Если программа не работает, обновите версию!
procedure LocationPrint(x, y: real);
begin
if x = 0 then
if y = 0 then Writeln('Начало координат')
else Writeln('Ось Y')
else
if y = 0 then Writeln('Ось X')
else
if x > 0 then
if y < 0 then Writeln('Четвертая четверть')
else Writeln('Первая четверть')
else
if y < 0 then Writeln('Третья четверть')
else Writeln('Вторая четверть')
end;
begin
loop 2 do
begin
var (x, y) := ReadReal2('Введите координаты x и y:');
LocationPrint(x, y)
end
end.
// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('Количество строк (столбцов) в матрице:');
Writeln('*** Исходная матрица ***');
var a:=MatrRandom(n,n,-99,99);
a.Println(4);
Println(4*a.ColCount*'-');
var i:=ReadInteger('Укажите номер столбца (счет от 1):');
if i.InRange(1,a.ColCount) then
begin
var col:=a.Col(i-1);
Println('Сумма элементов столбца',col.Sum,'max=',col.Max)
end
else
Println('Недопустимый номер колонки')
end.
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу, которая запросит у пользователя два числа и одине из знаков : + - * / и выведет на экран результат соответствующего арифметического действия. .
var a,b:real;
c:char;
begin
read(a,b,c);
if c='+' then writeln(a+b) else
if c='-' then writeln(a-b) else
if c='*' then writeln(a*b) else
if c='/' then writeln(a/b) else
writeln('символ не арифметического действия');
end.