Составьте программу вычисления суммы отрицательных элементов в массиве a[1..10]. + сделать чтобы это с .txt файла вводилось. я не знаю как, но тема "работа с текстовыми файлами".
Var i,k,s: integer; f: text; begin assign(f,'c.txt'); reset(f); s:=0; for i:=1 to 10 do begin read(f,k); write(k,' '); if k<0 then s:=s+k; end; close(f); writeln; writeln('сумма отрицательных: ',s); end.
Файл c.txt во вложении.
volodinnikolay19
08.12.2020
//написано на (си/си++) #include <iostream> #include <stdio.h>
if (x > y){ /*если x > y то он поменяет их местами*/ std::cout << "x и y поменяны местами\n" x ^= y; y ^= x; x ^= y; }else{ std::cout << "x и y не поменяны местами\n"; }
(пишу про язык си/си++) Зависит от ситуации.Например при создании динамического массива типа char он забивается абсолютно случайными значениями и для их перебора будет лучше присвоить всем элементам такого массива 0 как будто каждый элемент это конец строки (сделать это можно используя функцию memset()) После заполнить этот массив буквами (закинуть текст например при и тогда мы сможем перебрать этот массив циклом Пример: for (int i = 0; str[i] != 0;++i){...} где str[] это динамический массив.Еще один случай.Иногда вместо простой инициализации переменной нам нужно присвоить ей любое значение (иначе может не скомпилироваться т.к. там будет лежать не понятно что).Так же и с единицей.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составьте программу вычисления суммы отрицательных элементов в массиве a[1..10]. + сделать чтобы это с .txt файла вводилось. я не знаю как, но тема "работа с текстовыми файлами".
f: text;
begin
assign(f,'c.txt');
reset(f);
s:=0;
for i:=1 to 10 do
begin
read(f,k);
write(k,' ');
if k<0 then s:=s+k;
end;
close(f);
writeln;
writeln('сумма отрицательных: ',s);
end.
Файл c.txt во вложении.