vardartem876
?>

Определите, что будет напечатано в результате работы следующей программы. Pascal Алгоритмический язык Python Var y, і: integer; Begin y := 5; For і := 1 to 3 do y := y + 5*і; Writeln(y); End. алг нач цел y, i y := 5 нц для i от 1 до 3 y := y + 5 * i кц вывод y кон y = 5 for і in range(1, 4): y = y + 5 * і print

Информатика

Ответы

rashodnikoff

В ответе будет напечатано число 20.

Виталий
Uses Crt;
  const n=5; m=7;
  type Mas = array [1..n, 1..m] of integer;
  var i, j, j1, j2: integer;
      Sumj1, Sumj2: real;
      A: Mas;
begin
 ClrScr;
 Randomize;
 SumJ1:=0; SumJ2:=0;
 for i:=1 to n do
    for j:=1 to m do
    A[i,j]:=random (10);
 WriteLn (' Massiv A: ');
 for i:=1 to n do
   begin
      for j:=1 to m do
      Write (A[i,j]:4);
      WriteLn;
   end; WriteLn;
 repeat
   Write (' Stolbez #1 = ');    ReadLn(j1);
 until (j1>=1) and (j1<=m);
 repeat
   Write (' Stolbez #2 = '); ReadLn(j2);
 until (j2>=1) and (j2<=m) and (j1<>j2);
 for i:= 1 to n do
    SumJ1 := SumJ1+A[i,j1];
 for i:= 1 to n do
   SumJ2:=SumJ2+A[i,j2];
 SumJ1:=SumJ1/n; SumJ2:=SumJ2/n; 
WriteLn;
WriteLn (' Srednee stolbza ', j1, ' = ', SumJ1:4:2);
WriteLn (' Srednee stolbza ', j2, ' = ', SumJ2:4:2); 
ReadLn;
end.
Паскаль.составить программу, вычисляющую среднее значение по двум столбцам матрицы. номера столбцов
ale-protasov
function ptcrk(a,b,x,y,r: real): integer;
var k: integer;
begin
  k:=0;  
  if abs(sqr(x-a)+sqr(y-b)-r*r)<1.0e-9 then k:=1;
  if r*r-sqr(x-a)-sqr(y-b)>1.0e-9 then k:=2;
  ptcrk:=k;
end;
// основная программа
var a,b,x,y,r,k: real;
begin
  write('координаты центра a b: ');  readln(a,b);
  write('координаты точки x y: ');  readln(x,y);
  write('радиус: ');  readln(r);
  k:=ptcrk(a,b,x,y,r);
  if k=1 then writeln('точка на окружности');
  if k=2 then writeln('точка внутри круга');
  if k=0 then writeln('точка вне круга');
end.

координаты центра a b: 2 1
координаты точки x y: 4 1
радиус: 2.1
точка внутри круга

координаты центра a b: 2 1
координаты точки x y: 4 1
радиус: 2
точка на окружности

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Определите, что будет напечатано в результате работы следующей программы. Pascal Алгоритмический язык Python Var y, і: integer; Begin y := 5; For і := 1 to 3 do y := y + 5*і; Writeln(y); End. алг нач цел y, i y := 5 нц для i от 1 до 3 y := y + 5 * i кц вывод y кон y = 5 for і in range(1, 4): y = y + 5 * і print
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Bolshakova Shigorina
matoksana
evoque2014
aleksagrbec39
Сергеевна-С.А.1549
delfinmos
TrofimovAnastasiya828
olartamonov6
Novikova
Семеновна-Павел
natalyaSvetlana
marketing601
Kaccak8778
vsemvsego306
lionmost6979