evlampin
?>

1 задание Преобразовать одномерный массив вещественных чисел, присвоив каждому элементу квадрат его значения. (в Java) 2 задание Даны действительные числа s, t. Составить программу вычисления выражения f(t, -2s, 1.17) + f(2.2, t, s-t), где f(a, b, c) = (2a – b – sin(c)) / (5 + |c| (в Java)

Информатика

Ответы

bespalovaannaanna
Var
    a, b: integer;

function greatest_common_divisor(m, n: integer): integer;
var
    modulo: integer;
begin
    modulo := m mod n;
    if modulo = 0 then
        greatest_common_divisor := n
    else
        greatest_common_divisor := greatest_common_divisor(n, modulo)
end;

procedure reduce_the_fraction(a, b: integer);
var
    gcd: integer;
    sign: string;
begin
    gcd := greatest_common_divisor(a, b);
    if a * b < 0 then
        sign := '-';
    writeln(sign, abs(a) / gcd, '/', abs(b) / gcd);
end;

begin
    write('Enter two numbers: ');
    readln(a, b);
    reduce_the_fraction(a, b);
end.
anton-www1

Если это вопрос то тогда да.

Текстовые и графические алгоритмы, линейный алгоритм ( такие бывают )

Алгоритм (модель процесса решения задачи) может быть представлен в виде текста на естественном языке или графически (блок-схемой).

Алгоритм на естественном языке даёт человеку более подробную информацию, а блок схема – это наглядный представления информации. Алгоритм можно разделить по записи (форме представления) на текстовые (описание на естественном языке) и графические (блок-схемы). Алгоритм на естественном языке даёт более подробную информацию, а блок-схема – более наглядную.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1 задание Преобразовать одномерный массив вещественных чисел, присвоив каждому элементу квадрат его значения. (в Java) 2 задание Даны действительные числа s, t. Составить программу вычисления выражения f(t, -2s, 1.17) + f(2.2, t, s-t), где f(a, b, c) = (2a – b – sin(c)) / (5 + |c| (в Java)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

artemka56rus
kartyshkinaaa
Aleksei1463
zybin41iz81
sahar81305
adman7
Koranna1986
m-illarionov
linda3930
VSArsentev
Voronov434
d2904
Burov1446
anechcak
saniopt