hadzievamareta44
?>

Задачи на языке программирования С++ (repl.it Задача 1. Задан массив действительных чисел размерности 10х10. Найти суммы элементов каждой строки, произведения элементов каждого столбца, и максимальный элемент главной диагонали (подсказка: все элементы, для которых номер строки совпадает с номером столбца). Задача 2. Задан одномерный массив целых чисел. Образуйте из него два отсортированных по возрастанию массива, содержащих четные и нечетные числа. Задача 3. Задан генератором случайных чисел одномерный массив из действительных чисел. Найдите максимальное и минимальное число этого массива. Задача 4. Решето Эратосфена число – это любое целое число, которое точно делится без остатка только само на себя и 1. Решето Эратосфена работает следующим образом: 1) Создайте массив, все элементы которого имеют начальное значение 1 (истина). Элементы массива с индексами останутся равными 1. Все другие элементы массива, в конечном счете, установятся равными нулю. 2) Начиная с индекса массива 2 (индекс 1 должен быть каждый раз отыскивается элемент массива с единичным значением, циклически обрабатывается оставшаяся часть массива и устанавливается в нуль каждый элемент массива, чей индекс кратен индексу элемента с единичным значением. Для индекса 2 все элементы в массиве с большим чем 2 индексом и кратные 2 установятся равными нулю (индексы 4, 6, 8, …); для индекса 3 все элементы с индексом свыше 3 и кратные 3, установятся равными нулю (индексы 6, 9, 12, …) и т.д. 3) Когда процесс закончится, элементы массива с единичным значением указывают, что их индексы числа. Эти индексы могут быть напечатаны.

Информатика

Ответы

abadaeva
Dim s, s1, s0, t As String        'строка, первая буква слова, слово, список нужных слов
s = InputBox("Введите строку:")
Do
    Do
        n = n + 1
        If s1 = "" Then s1 = Mid(s, n, 1)            'запоминаем первую букву слова
        If Mid(s, n, 1) = s1 Then m = m + 1       'считаем, сколько раз она встретилась
        s0 = s0 & Mid(s, n, 1)                          'запоминаем слово
        If n > Len(s) Then Exit Do
    Loop While Mid(s, n, 1) <> " "
If m = 1 Then t = t & s0                                 'переносим слово в список
m = 0                       'сбрасываем промежуточные переменные в исходное состояние
s1 = ""
s0 = ""
Loop Until n > Len(s)
If t = "" Then t = "Искомых слов нет"
MsgBox (t)
sedalex

На C++

 

#include <iostream>
using std::cout;

using std::cin;
using std::endl;
#include <cstdlib>
using std::rand;
using std::srand;
#include <ctime>
using std::time;

int main()
{
   int B[4][5];
   int sum[5] = { 0 };
   long product = 1;

   srand(time(0));

   //Инициализировать массива значениями от 0 до 9 и вывести таблицу на экран
   for(int i = 0; i < 4; i++)
   {
      for(int j = 0; j < 5; j++)
      {
         B[i][j] = rand() % 10;
         cout << B[i][j] << ' ';
      }
      cout << endl;
   }
   cout << endl;

   //Записать в одномерный массив сумму эллементов столбца
   for(int i = 0; i < 5; i++)
   {
      for(int j = 0; j < 4; j++)
      {
         sum[i] += B[j][i];
      }
   }


   //Вывести на экран значения одномерного массива
   for(int i = 0; i < 5; i++)
   {
      cout << sum[i] << ' ';
   }
   
   //Вычесление произведения(умножения)
   for(int i = 0; i < 5; i++)
   {
      product *= sum[i];
   }

   cout << "\n\nProduct = " << product << endl;

 

   cin.get();
   return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задачи на языке программирования С++ (repl.it Задача 1. Задан массив действительных чисел размерности 10х10. Найти суммы элементов каждой строки, произведения элементов каждого столбца, и максимальный элемент главной диагонали (подсказка: все элементы, для которых номер строки совпадает с номером столбца). Задача 2. Задан одномерный массив целых чисел. Образуйте из него два отсортированных по возрастанию массива, содержащих четные и нечетные числа. Задача 3. Задан генератором случайных чисел одномерный массив из действительных чисел. Найдите максимальное и минимальное число этого массива. Задача 4. Решето Эратосфена число – это любое целое число, которое точно делится без остатка только само на себя и 1. Решето Эратосфена работает следующим образом: 1) Создайте массив, все элементы которого имеют начальное значение 1 (истина). Элементы массива с индексами останутся равными 1. Все другие элементы массива, в конечном счете, установятся равными нулю. 2) Начиная с индекса массива 2 (индекс 1 должен быть каждый раз отыскивается элемент массива с единичным значением, циклически обрабатывается оставшаяся часть массива и устанавливается в нуль каждый элемент массива, чей индекс кратен индексу элемента с единичным значением. Для индекса 2 все элементы в массиве с большим чем 2 индексом и кратные 2 установятся равными нулю (индексы 4, 6, 8, …); для индекса 3 все элементы с индексом свыше 3 и кратные 3, установятся равными нулю (индексы 6, 9, 12, …) и т.д. 3) Когда процесс закончится, элементы массива с единичным значением указывают, что их индексы числа. Эти индексы могут быть напечатаны.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

terehin863
janepustu
sashaleb88
zvanton
okison2847
kmr495270
muzaffarovich-Sergei1777
rstas
tefdst
msk27
Khiryanov
Galkin Vladimirovich729
rusdtver
lika080489
stsnab