Komarovsergeysk
?>

Даны 10 чисел, вывести те из них, которые являются полными квадратами. Составить программу паскаль.

Информатика

Ответы

evg-martenyuk

const

 n = 10;

var

 i, x, q: integer;

begin

 for i := 1 to n do

   begin

   read(x);

   q := trunc( sqrt(x) );

   if sqr(q) = x then

     write(x,' ');

   end;

end.

Lebedeva1577
Program lol (input, output);
var i, n, d, sd, s4d, kd, kn4d, k4d, kbd:integer;
begin
writeln ('Введите само число и число d');
read (n, d);
writeln ('Делители:');
I:=1;
sd:=0;
s4d:=0;
kd:=0;
kn4d:=0;
k4d:=0;
kbd:=0;
while I <=n do
begin
if n mod I = 0 then
begin
kd:=kd+1;
writeln (I);
sd:=sd+I;
if I > d then
kbd:=kbd+1;
if I mod 2 = 0 then
begin
s4d:=s4d+I;
k4d:=k4d+1;
end
else
kn4d:=kn4d+1;
end;
I:=I+1;
end;
writeln (' ');
writeln ('сумма делителей ', sd);
writeln ('сумма четных делителей ', s4d);
writeln ('количество делителей ', kd);
writeln ('количество нечетных делителей ', kn4d);
writeln ('количество четных делителей ', k4d);
writeln ('количество делителей болеше d ', kbd);
end.
gk230650
В шестеричной системе алфавит состоит из цифр 0,1,...5.
Четырехразрядное число по условиям задания (1) и (2) имеет вид aabb,
где a=1,2,...5, b=0,1,...5.
В развернутой записи число имеет вид
a×6³+a×6²+b×6+b×1 = 6²×a(6+1)+b(6+1) = 7(36a+b)
При этом по условию (3) можно записать, что k² = 7(36a+b)
Чтобы число 7(36a+b) было полным квадратом, 36a+b должно быть кратно 7, а остаток от деления (36a+b) на 7 также должен быть полным квадратом.
Получаем, что 36a+b = 7m²
Минимальное значение 36a+b равно 36×1+0 = 36, следовательно m>2 (при m=2 получим 7×4=28, что меньше 36).
При m=3 получаем 36a+b = 63 и при a∈[1;5], b∉[0;5] решений нет.
При m=4 получаем 36a+b = 112 и находим a=3, b=4 - есть решение!
При m=5 получаем 36a+b = 175 и при a∈[1;5], b∉[0;5] решений нет.
При m=6 получаем 36a+b = 175 и получаем, что a=7, а это недопустимо. Дальше смысла проверять нет.
Итак, a=3, b=4, число 3344₆ = 7×(36×3+4) = 784₁₀ = 28²

ответ: 3344

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны 10 чисел, вывести те из них, которые являются полными квадратами. Составить программу паскаль.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Garifovich Greshilova791
romashka17-90
snip99
ЕВ1873
lele4kass
utkinslava
ann-perminova2008
Банова_Елена431
iivanov54
priemni451
myatadinamo
smokestylemos
gorodof4292
stalker2201
Zhanibekrva Kandaurova