Поделитесь своими знаниями, ответьте на вопрос:
1) В вход программы поступают N 1000 натуральных чисел, каждое из которых не превышает 10000. Необходимо определить количество пар элементов (ai, aj) этого набора, в которых 1 i < j N, сумма элементов нечётна, а произведение делится на 13. Напишите эффективную по времени и по памяти программу для решения этой задачи. Описание входных и выходных данных В первой строке входных данных задаётся количество чисел N (1 ≤ N ≤ 1000 В каждой из последующих N строк записано одно натуральное число, не превышающее 10000. Пример входных данных: 5 4 13 27 39 7 Пример выходных данных для приведённого выше примера входных данных: 2 В приведённом наборе из 5 чисел имеются две пары (4, 13) и (4, 39), сумма элементов которых нечётна, и произведение кратно 13.
#include <iostream>
using namespace std;
bool check(int a, int b){
return ((a + b) & 1) && (a * b) % 13 == 0;
}
int main(){
int n, cnt = 0;
cin >> n;
int a[n];
for(int i = 0; i < n; i++)
cin >> a[i];
for(int i = 0; i < n; i++)
for(int j = i + 1; j < n; j++)
cnt += check(a[i],a[j]);
cout << cnt;
}