Simbireva
?>

Уровень B. Напишите программу, которая получает с клавиатуры натуральное число и определяет, сколько раз в его десятичной записи встречается цифра 1.

Информатика

Ответы

re-art

uses School;

begin

 Digits(ReadInt64).Count(p -> p = 1).Print

end.

Объяснение:

School - стандартная библиотека для решения школьных задач, вошедшая в PascalABC.NET, начиная с версии 3.6.3


Уровень B. Напишите программу, которая получает с клавиатуры натуральное число и определяет, сколько
westgti77105

Ну или для PascalABC.NET Более старых версий (Не имеющих поддержки библиотеки School):

begin

 ReadInt64().ToString.ToCharArray.Count(p -> p = '1').Println;

end.

Объяснение:

Анна1417

#include <iostream>

#include <vector>

#include <set>

#include <cmath>

using namespace std;

bool check(double a, double b, double c){

   return !(a >= b + c || b >= a + c || c >= b + c);

}

double square(double a, double b, double c){

   double p = (a+b+c)/2;

   return sqrt(p * (p-a) * (p-b) * (p-c));

}

bool is_palind(int k){

   string s = to_string(k);

   for(int i = 0; i < s.length() - i - 1; i++)

       if(s[i] != s[s.length()-i-1])

           return false;

   return true;

}

void solve1(){

   vector<double> lines(4);

   double ans = -1;

   for(auto &i : lines) cin >> i;

   for(int i = 0; i < 4; i++)

       for(int j = i + 1; j < 4; j++)

           for(int k = j + 1; j < 4; j++)

               if(check(lines[i],lines[j],lines[k]))

                   ans = max(ans,square(lines[i],lines[j], lines[k]));

   ans == -1 ? cout << "No solution" : cout << ans;

}

void solve2(){

   set<int> s;

   for(int i = 1000; i < 10000; i++)

       if(is_palind(i))

           s.insert(i);

   int n;

   cin >> n;

   s.find(n) != s.end() ? cout << n : cout << *upper_bound(s.begin(),s.end(),n);

}

Yurevich1701
Байт – это последовательность из восьми бит
К расширениям графических файлов можно отнести gif, bmp, jpg3
К расширениям готовых к исполнению программ можно отнести exe, com, bat

Принтер – устройство кодирования (неверно, устройство вывода)
Клавиатура – устройство ввода (верно)
Монитор – устройство ввода(неверно, вывода)
CD- ROM – устройство  кодирования информации (неверно, ввода-вывода)
 Минимально необходимый набор устройств для работы компьютера содержит системный блок (не пустой, конечно))) ), монитор, клавиатуру.
 Манипулятор «мышь» это устройство ввода
Постоянное запоминающее устройство служит для хранения программ начальной загрузки компьютера и тестирование его узлов.
При отключении компьютера информация стирается из оперативной памяти. 
10 - raskaz.txt
11. Чему равен 1 Мбайт?
1000000 байт (СИ)
1024 Кбайт (IEC)
12.для копирования надо выделить нужный фрагмент
13 не пачкать и не царапать!
14ю когда с файлами работаешь, если у тебя java работает - через браузер запросто, по сетке тоже можно поцепить
16. вирусы пишут специально, они умеют размножаться, заражают другие проги, портят файлы, калечат реестр, шифруют данные, заползают в загрузочные сектора. некоторые незаметно проникают и ожидают команды извне. а некоторые сами себя модифицируют
15. всеми перечисленными зависит от вируса.
17. Поставить файрволл и антивир и периодически обновлять базы данных. НИКОГДА не открывать подозрительные файлы из ненадежных источников. проверять антивиром флешки и полученные файлы перед открытием. делать бэкапы системы и копии важных данных. периодически сканировать комп антивиром.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Уровень B. Напишите программу, которая получает с клавиатуры натуральное число и определяет, сколько раз в его десятичной записи встречается цифра 1.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

di-bobkov1985
Elizavetaborisovna1992
mlubov1
boykoz9
ietishkin
rabchek145200614
Aleksandrovna-Marina
Natalya
bykovaam
olma-nn477
braigon974
format-l3364
Adabir20156806
denbelousov963
mtcover