dimalihachew
?>

В питоне написать программу: 1. Дана строка. Если в этой строке буква f встречается только один раз, выведите её индекс. Если она встречается два и более раз, выведите индекс её первого и последнего появления. Если буква f в данной строке не встречается, ничего не выводите. 2. Написать генерацию строк длины 12, первые 5 символов которой - четные цифры, следующие 5 символов - буквы 'a' - 'z', следующие 2 символа - "AB", если среди первых пяти символов строки есть цифра 8, "XY" - если нет.

Информатика

Ответы

ivanovanata36937365

Решим последовательно обе задачи:

Объяснение:

Задача 1

Для поиска индексов будем использовать методы index и rindex. Решение приведено на скриншоте

Задача 2

Для реализации алгоритма нам понадобятся два модуля: random (обязательно) и string (для облегчения жизни).

Сначала создадим два списка: с буквами (a_z_letters) и с числами (even_numbers), сразу приведенными к типу str (для простоты дальнейших манипуляций).

Далее с random.choice() сгенерируем пять случайных цифр и пять случайных букв.

Последним действием станет проверка на наличие цифры 8 в сгенерированной строке. Если такая есть, то прибавим к строке "АВ", иначе - прибавим "ХY".


В питоне написать программу: 1. Дана строка. Если в этой строке буква f встречается только один раз,
В питоне написать программу: 1. Дана строка. Если в этой строке буква f встречается только один раз,
ka-shop
При копировании кода из IDE на сайт автоматически удаляется перенос строки. Будет прикреплен скриншот того, как должен выглядеть код

program p1;var i: integer;beginfor i:=1 to 10 dowriteln('5*'+i+'='+5*i);end.

____________________

program p1;var a, b, c, d, e, sum: integer;beginwrite('Введите первое число >> ');read(a);write('Введите втроое число >> ');read(b);write('Введите третье число >> ');read(c);write('Введите четвертое число >> ');read(d);write('Введите пятое число >> ');read(e);sum:=a+b+c+d+e;writeln('Сумма введенных чисел: '+sum);end.

1.вывести на экран таблицу умножения на 5 5*1=5 5*2=10 5*10=50 2. программа просит ввести 5 чисел и
1.вывести на экран таблицу умножения на 5 5*1=5 5*2=10 5*10=50 2. программа просит ввести 5 чисел и
marinazubcko16729

1.Найти сумму чётных цифр числа.

uses crt;
var a,x:integer;
i,s:integer;
begin
clrscr;
writeln('Vvedite chislo');
readln( a ); x:=a;
s:=0;
while ( x<>0 ) do
begin
if x mod 2 =0 then s:= s + (x mod 10);
x:= x div 10;
end;
writeln( 'Summa= ', s );
readln;
end.

 

2.Вывести на экран таблицу умножения.

uses crt;
var a: array [1..10,1..10] of integer;
i,j:integer;
begin
clrscr;
for i:=2 to 10 do
begin
writeln;
for j:=1 to 10 do
write(i*j,'  ');
end;
writeln;
readln;
end.

 

3.Найти все двухзначные числа, сумма которых равна а.

uses crt;
var a,x,i,s:integer;
begin
clrscr;
writeln('Vvedite a');
readln(a);
for i:=10 to 99 do
begin
x:=i;
s:=0;
while (x<>0) do
begin
s:=s+(x mod 10);
x:=x div 10;
end;
if s=a then write(i,' ');
end;
readln;
end.

 

4.Найти количество и сумму чётных делителей.

uses crt;
var s,k,i,a:integer;
begin
clrscr;
writeln('Vvedite chislo');
readln(a);
i:=2;
s:=0;
k:=0;
while i<>a do
begin
if (a mod i =0) and (i mod 2=0) then
begin
s:=s+i;
k:=k+1;
end;
i:=i+1;
end;
writeln('Summa chisletelei =',s);
writeln('Kolichestvo delitelei= ',k);
readln;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

В питоне написать программу: 1. Дана строка. Если в этой строке буква f встречается только один раз, выведите её индекс. Если она встречается два и более раз, выведите индекс её первого и последнего появления. Если буква f в данной строке не встречается, ничего не выводите. 2. Написать генерацию строк длины 12, первые 5 символов которой - четные цифры, следующие 5 символов - буквы 'a' - 'z', следующие 2 символа - "AB", если среди первых пяти символов строки есть цифра 8, "XY" - если нет.
Ваше имя (никнейм)*
Email*
Комментарий*