alenih13
?>

Дано натуральное число. Напишите программу, которая проверяет, является ли число трехзначным, и если да, то найдите сумму цифр

Информатика

Ответы

obelov

Решение на скриншоте


Дано натуральное число. Напишите программу, которая проверяет, является ли число трехзначным, и если
jaksonj326

a=int(input('Введите первое число: ')

b=int(input('Введите второе число: ')

c=int(input('Введите третье число: ')

if a > b and c:

  print('Наибольшее число: ',a)

elif b > a and c:

  print('Наибольшее число: ',b)

else c > b and a:

  print('Наибольшее число: ',c)

Объяснение:

Первые три команды отвечают за добавление переменным значение, которые будут введены пользователем.

if,elif,else ставят условие, при котором будет выполнено следующие условия, так как переменных 3, то мы вводим ее три раза, каждый раз редактируя ее.

Все они сделаны по таком принципу, если True(правда), то выполнить действие, если False(неправда), то действие отменяется.

В данных командах написано, если а больше b и c, то выполнится условие и на экран выведится текст, с наибольшем числом a.

Если условие не выполняется, программа переходит к условию ниже, если оно аналогично не выполняется, оно переходит к третьему.

olgapotapova

Uses
  Crt;
Var
  i, N, kol: byte;
  sum_rost, sr_rost: real;
  team: array[1..100] of real;
Begin
  sum_rost := 0.0;
  sr_rost := 0.0;
  kol := 0;
  write('Введите количество членов команды');
  read(N);
  writeln('Введите рост каждого члена команды');
  for i := 1 to N do
    begin
      readln(team[i]);
      sum_rost := sum_rost + team[i];
    end;
  sr_rost := sum_rost / N;
  for i := 1 to N do
    if (team[i] > sr_rost) then
      kol := kol + 1;
  writeln('Количество членов команды, рост которых превышает средний по команде (', sr_rost:4:2, ')');
  write(' равно ', kol);
End.

Я надеюсь надо было на паскале написать?)

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано натуральное число. Напишите программу, которая проверяет, является ли число трехзначным, и если да, то найдите сумму цифр
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

itartdesignprof
office46
Ladiga_Evgenii886
bellaalya13862
d43irina
andre6807
Japancosmetica
Kisuha8465
a8227775
Dampil
Aleksandrovna1153
сергеевич1958
keldastrand
Sakmarov
oaved2018