Диана820
?>

Напишите программу, которая получает с клавиатуры натуральное силосы и определяет, сколько цифр в его десятичной записи. ПИТОН

Информатика

Ответы

papanovar

print(len(str(int(input(

fursov-da
Const
  n = 5;{ это позволяет в одном месте изменить количество чисел }

type
  numeric = real;{ это позволяет в одном месте изменить тип чисел }

var
  max, min: numeric;
  i: integer;
  a: array[1..n] of numeric;

begin
  Writeln('Введите ', n, ' произвольных чисел через пробел');
  Read(a[1]);
  min := a[1]; max := min;
  for i := 2 to n do
  begin
    Read(a[i]);
    if max < a[i] then max := a[i]
    else
    if min > a[i] then min := a[i]
  end;
  Writeln('Минимальное введенное: ', min, ', максимальное: ', max)
end.

Тестовое решение:
Введите 5 произвольных чисел через пробел
34 157 -84.54 14.843 -13.64
Минимальное введенное: -84.54, максимальное: 157
mikhail
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 #include <iostream> #include <windows.h> using namespace std; void main() {     SetConsoleOutputCP(1251);     int num, col;     int a=0;     int min;     cout << "Программа которая находит минимальное из введенных пользователем чисел." << endl;     cout << "Сколько чисел вы введёте ?" << endl;     cin>>col; cin>>num; min=num;     do {     cout << "Введите число --> ";     cin >> num;     if (min>num) {     min=num;     }     a++;     } while (a < col-1); cout<<min<<endl; }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая получает с клавиатуры натуральное силосы и определяет, сколько цифр в его десятичной записи. ПИТОН
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

olgaprevisokova302
Бочкарева Горохова1652
best00
Владислав-Аветисян217
arturusinsk5
Максим_Нина
dkedrin74038
zrs-546
alenih13
Gesper63
marinakmaa86
Dmitriy2211104
baeva-larisa8165
Александра Викторович531
Ushakova Sakhno