Поделитесь своими знаниями, ответьте на вопрос:
Задается натуральное число q равное площади некоторого прямоугольника. напишите программу, определяющую количество прямоугольников имеющих площадь q, стороны которых выражены натуральными числами. на с++, с цикла с предусловием или постусловием.
using namespace std;
int main()
{
setlocale(LC_ALL, "RUS"); //Для русского языка в консоли
int a,b,//a,b - стороны
q, //q - площадь
end, //end - выход из программы
num; //num - количество подходящих прямоугльников
cout << "Введите площадь:" << endl;
cin>>q;
end=0;
num=0;
while (end==0)
{
cout <<"Введите стороны a,b прямоугольника. 0, чтобы выйти"<<endl;
cin>>a>>b;
if (a<=0 || b<=0)
{
end=1;
}
else
{
if (a*b==q)
{
num++;
}
}
}
cout <<"Среди введенных прямоугольников площадь "<<q<<" имели " <<num <<" штук"<<endl;
return 0;
}