laktionova-natal
?>

Написать программу для решения следующих задач: 1) Вывести на экран все двузначные числа: а) В столбик б) В строчку 2) Вывести на экран целые числа из интервала [-15; 10]; 3) Вывести на экран целые числа из интервала [-5; 5] в обратном порядке; 4) Вывести на экран все четные двузначные числа; 5) Найти и вывести на экран сумму всех двузначных чисел; 6) Найти и вывести на экран сумму всех целых чисел из интервала [-100; 51];

Информатика

Ответы

larazaytseva

1) 

var a:array [1..100] of integer;

n,i:integer;

begin

for i:=10 to 99 do begin

a[i]:=i;

if (a[i] mod n=0) then writeln(a[i]);

end;

end.

 

 2)

var a:array [1..100] of integer;

n,k,i,x,y,z: integer;

begin

readln(n,k);

for i:=n to k do begin

a[i]:=i;

x:=a[i] mod 10;

y:=a[i] div 10;

z:=y mod 10;

y:=y div 10;

if (x=y) or (x=z) or (y=z) then writeln(a[i]);

end;

end.

 

 3)

 var a,n,an,na: integer;

begin

readln(a,n);

if (a>0) and (b>0) then begin

an:=a*10+n;

na:=n*10+a else writeln('Введены неверные числа!');

end;

end.

saidsaleh881
#include <iostream>
#include <list>

using namespace std;

int main() {
    list<int>mylist;
    //Делаем со списком, что хотим
    mylist.push_back(1);
    mylist.push_back(2);
    mylist.push_back(3);
    mylist.push_back(-4);
    mylist.push_back(5);
    for (auto i : mylist) {
        cout << i << " ";
    }
    cout << "\n";
    //Удаляем последний отрицательный элемент
    auto it = mylist.end();
    while (*it > 0) {
        if (it == mylist.begin()) {
            cout << "Not found.\n";
            return 0;
        }
        it--;
    }
    //Делаем со списком, что хотим
    mylist.erase(it);
    for (auto i : mylist){
        cout << i << " ";
    }
    return 0;
}
annakuznetsova841

использовать Чертежник

алг

нач

цел в, г

вывод "Введите количество повторов по вертикали: "

ввод в

вывод "Введите количество повторов по горизонтали: "

ввод г

нц в раз

нц г раз

опустить перо

сместиться на вектор (0,1)

сместиться на вектор (1,0)

сместиться на вектор (0,-1)

сместиться на вектор (-1,0)

поднять перо

сместиться на вектор (-1,0)

опустить перо

сместиться на вектор (0,1)

сместиться на вектор (1,1)

сместиться на вектор (1,0)

сместиться на вектор (1,-1)

сместиться на вектор (0,-1)

сместиться на вектор (-1,-1)

сместиться на вектор (-1,0)

сместиться на вектор (-1,1)

поднять перо

сместиться на вектор (-1,0)

опустить перо

сместиться на вектор (0,1)

сместиться на вектор (2,2)

сместиться на вектор (1,0)

сместиться на вектор (2,-2)

сместиться на вектор (0,-1)

сместиться на вектор (-2,-2)

сместиться на вектор (-1,0)

сместиться на вектор (-2,2)

поднять перо

сместиться на вектор (5,0)

кц

сместиться на вектор (-(г*3),-3)

кц

кон

Объяснение:

картинка


3. Составьте программу рисования узора, показанного на рисунке. Количество повторений элементов узор

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу для решения следующих задач: 1) Вывести на экран все двузначные числа: а) В столбик б) В строчку 2) Вывести на экран целые числа из интервала [-15; 10]; 3) Вывести на экран целые числа из интервала [-5; 5] в обратном порядке; 4) Вывести на экран все четные двузначные числа; 5) Найти и вывести на экран сумму всех двузначных чисел; 6) Найти и вывести на экран сумму всех целых чисел из интервала [-100; 51];
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

teta63
Kotvitskii
vasearu
rigina82
Varagyant
Nikolai172
ilyxa08
Lorvi_Shevkunova849
ecogoi
Shteinbakh
sleek73
Taniagrachev
dmitryshigin
Zolotnik974620
verynzik66525