Pavlovna-Golovitinskaya378
?>

Нужно) паскаль авс дан текст. слова в тексте разделены одним или несколькими пробелами. написать программу, выводящую все слова в алфавитном порядке

Информатика

Ответы

Anatolevna
uses crt;
var s,s1:string;    
a:array[1..100] of string;    
n,i,j,k:byte;
begin
clrscr;
writeln('Введите текст из слов, разделенных пробелами');
readln(s);
s:=' '+s+' ';{добавим пробел в начало и в конец}
n:=length(s);
i:=2; k:=0;{всего слов}
while i<=n do
if (s[i]<>' ')and (s[i-1]=' ') then{если не пробел а перед ним пробел}  
begin  
k:=k+1;{+ слово}  
j:=i;  
s1:='';  
while (j<=n) and (s[j]<>' ') do {пока не пробел и не конец строки}    
begin    
s1:=s1+s[j];    
j:=j+1;    
end;  
a[k]:=s1;{пишем его в массив}  
i:=i+length(s1);{перешагиваем через слово}  
end
else
i:=i+1;{пропускаем пробелы}
for i:=1 to k-1 do {сортируем массив по возрастанию=по алфавиту}
for j:=i+1 to k do if a[i]>a[j] then  
begin  
s1:=a[i];  
a[i]:=a[j];  
a[j]:=s1  
end;
writeln('Слова текста в алфавитном порядке:');
for i:=1 to k do
writeln(a[i]);
readln
end.
znaberd786
Var s: string;
begin
  readln(s);
  writeln(s.ToWords.Sorted.JoinIntoString(' '));
end.

это строка для проверки
для проверки строка это
bakerkirill

Что такое дизайн и его роль в общественной жизни

Диза́йн — это творческий метод, процесс и результат художественно-технического проектирования промышленных изделий, их комплексов и систем, ориентированного на достижение наиболее полного соответствия создаваемых объектов и среды в целом возможностям и потребности человека, как утилитарным, так и эстетическим.

«Дизайн» – это творческая деятельность, целью которой является определение формальных качеств промышленных изделий. Эти качества включают и внешние черты изделия, но главным образом те структурные и функциональные взаимосвязи, которые превращают изделие в единое целое как с точки зрение потребителя, так и с точки зрения изготовителя. Дизайн стремится охватить все аспекты окружающей человека среды, которая обусловлена промышленным производством.

Дизайн - специфический ряд проектной деятельности, объединивший художественно-предметное творчество и научно обоснованную инженерную практику в сфере индустриального производства.

golovins3

ФУНКЦИИ ДИЗАЙНА

Разработка и создание объектов графики и графического дизайна является не только одним из направлений изобразительно-художественной деятельности человека, но и позволяет разрешить некоторые важные вопросы. Имея вполне практическое значение, графический дизайн обладает рядом следующих функций:

функция первая – различие подчеркнуть индивидуальность, дизайн дифференцирует и сортирует формированию внешних отличительных особенностей аналогичных объектов, предметов и вещей, либо компаний и фирм, выполняющих деятельность в единой среде;

функция вторая – предоставление информации. Многие продукты графического дизайна (например, дорожные знаки, вывески, инструкции с использованием рисунков и прочее) призваны передать зрителю (потенциальному потребителю, заказчику или иному заинтересованному лицу) ту или иную важную информацию;

функция третья – эмоциональное взаимодействие. Создаваемые при изображений, различных цветов и приемов, объекты графического дизайна вызывать определенные ассоциации, формировать какой-либо образ в определении и причислении объекта к окружающему предметному миру.

Как правило, в профессиональной сфере имеет место каждая из перечисленных функций, что делает предметы, выполненные с использованием графического дизайна, наиболее эффективными и востребованными инструментами в области рекламы, маркетинга и социальной сферы, позволяя осуществлять контакт с основной аудиторией при визуального взаимодействия.

Подробнее с определением, видами графики и дизайна

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно) паскаль авс дан текст. слова в тексте разделены одним или несколькими пробелами. написать программу, выводящую все слова в алфавитном порядке
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

preida-2
terehin863
sancity997124
sveta740450
emartynova25
druzhbamagazin2457
kirillprotopopov1
ИванМолчанов
Иванович621
Abespal
andr77716
litlenet
zuzman601
zhunina71807
format-l3364